Connection refused?

No there's still something screwy going on.. While I CAN telnet to either port 80 or 20000 from the same machine, if I try navigating to EITHER from a browser I get connection refused.

iptables and ufw not installed.

iptables --list
-bash: iptables: command not found
~ $ ufw status
-bash: ufw: command not found

Something is blocking.
Did you install any kind of firewall or IPs or threat prevention program?

SSH is being allowed !
Did you have to add that access to be allowed anywhere?

No I don't have any of that stuff installed.. at least not explicitly. This is a fresh install of HassOS on a raspberry pi. TBH I'm not super familiar with the distro, but I wouldn't expect it to have firewalls preconfigured, etc.

I also tried

telnet 80

on my desktop machine, and it also gets refused a connection. You're right.. It really seems like something on that pi is blocking incoming network connections but hell if I know how. Interestingly the webui on port 8123 accepts connections just fine... Also SSH is working fine. No I didn't have to monkey with anything to get that stuff to work.

1 Like

Check the HassOS documentation.

I have.. This all came out of following their docs to get stuff set up.. No mention of these problems. In theory everything should just work lol

1 Like

You will need to find that needle in this haystack.
Until that is resolved all connections will be refused :frowning:

dinner calls...

boo.. Ok, well there's obviously something going on.. I'm further ahead than I was.. Thx for your help :slight_smile:

1 Like

Please login to port 8123
Then find and show everything that has been added on.

How did you install certbot?

I installed certbot with

apk add certbot

As to stuff I've added on, it's a clean install with the exception of I added the ssh addon, and set up the hugh extension. That and the stuff I've added for troubleshooting this all installed via apk: python2, and telnet

There is an add-on for letsencrypt in the system.

I say remove the certbot you installed and add the letsencrpt found in the add-on store.

Yeah I tried that too with a similar result. But now I've found that the DDNS client on my router isn't working and I'm not even pointed to the right IP anymore. Off to go find a solution for that now lol..

1 Like

So after much monkeying and and googling I couldn't figure out what was going on. No iptables or ipchains or any other firewall software running on that hassio distro as far as I could tell. So I decided to try ditching the pi, and just running Debian on a virtual machine.

Voila, problem solved. Everything just works as expected now, so there was definitely something going on with hassio that was blocking traffic other than the 8123 for HA itself. Weird. Anyways, I'm just going to carry on with HA installed on debian for now.

Thanks for all your help gents!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.