Connection not secure on CentOS 6


#21

I did what you said and it did not work, I tried resetting apache as well.
Should I wait a little? Will it take up to a week as @JuergenAuer said?


#22

No, the rate limit thing is irrelevant for what we’re trying to do. We already have a valid certificate. Changes should apply immediately.

Which part doesn’t work for you? Your site started working for me:

Try close/open your browser/tab.


#23

Oh sick, I was refreshing the site so I saw an unsecure connection, worked well after I opened a new tab.

Thank you for your help, humm… I’m not so sure of what was the problem and what we did in order to fix it, can you give me a short brief?

We basically swapped the keys that were configured in the SSL config with the ones certbot created? Should it recognize the keys on its own and use them?


#24

I think the summary of the issue is that Certbot did not understand how to install your certificate into your existing Apache configuration. It tried to do it, but your Apache used the existing self-signed certificate anyway.

So we had to give it a little help by changing the references to the self-signed certificate, to the Let’s Encrypt certificate.

When the certificate automatically renews later, you shouldn’t need to do anything, because the certificate/key paths will remain the same.


#25

I believe this is a known problem on CentOS having to do with the _default_ certificate, which a number of other people have encountered. I think we have to do something more proactive about this prevalent problem. :frowning:


#26

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.