Connection failure, firewall is open, Apache

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: ormutual.com

I ran this command: certbot --apache

It produced this output:

certbot --apache
Saving debug log to /var/log/letsencrypt/letsencrypt.log

Which names would you like to activate HTTPS for?


1: ormutual.com
2: syslog01.ormutual.com


Select the appropriate numbers separated by commas and/or spaces, or leave input
blank to select all options shown (Enter 'c' to cancel): 2
Requesting a certificate for syslog01.ormutual.com

Certbot failed to authenticate some domains (authenticator: apache). The Certificate Authority reported these problems:
Domain: syslog01.ormutual.com
Type: connection
Detail: 205.159.250.41: Fetching http://syslog01.ormutual.com/.well-known/acme-challenge/cnHcYTsK4vTYWZYx6Y48UrFEebAjZPJwxgzsENxZLV4: Timeout during connect (likely firewall problem)

Hint: The Certificate Authority failed to verify the temporary Apache configuration changes made by Certbot. Ensure that the listed domains point to this Apache server and that it is accessible from the internet.

Some challenges have failed.
Ask for help or search for solutions at https://community.letsencrypt.org. See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details.

My web server is (include version): Apache/2.4.52 (Ubuntu)

The operating system my web server runs on is (include version): Ubuntu 22.04.3

My hosting provider, if applicable, is: n/a

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 1.21.0

I have the ufw open for Apache, as we can see here:

ufw status
Status: active

To Action From


Apache Full ALLOW Anywhere
514 ALLOW Anywhere
22/tcp ALLOW Anywhere
Apache Full (v6) ALLOW Anywhere (v6)
514 (v6) ALLOW Anywhere (v6)
22/tcp (v6) ALLOW Anywhere (v6)

Thanks for any assistance you can provide.

2 Likes

The names shown have different IPs:

Name:    ormutual.com
Address: 198.185.159.144

Name:    syslog01.ormutual.com
Address: 205.159.250.41

Which IP is this server at?
Show:
curl -4 ifconfig.io

4 Likes

205.159.250.41

Yeah ormutual.com is our main site, I just need one specifically for this syslog box, you saw my notes on ufw (firewall), it's wide open for Apache traffic atm.

I can't reach your syslog01 domain using HTTP (or anything) from the public internet. And, neither can the Let's Debug test site which tries with the Let's Encrypt staging system.

Are you able to connect from outside your local network? Even try a mobile phone with wifi disabled

6 Likes

Good call. I normally work over a VPN, and I cannot get to it either remotely when I shut that off. I'll schedule some time with one our network engineers today.

2 Likes

Yep, that was it. Poked a hole in the network firewall, and I was able to grab a cert immediately. Thanks for the quick responses!

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.