Complete noob struggling with properly getting a cert, and viewing web app

Hello, I’m trying to get SSL for my domains.
I’ve gone through with the steps here: using the ‘sudo certbot --nginx’ command

Process looked relatively easy, however once complete, I was not able to view my websites.
I restarted nginx, and still no result
I’ve also restarted the pm2 processes with no result.
The websites just timeout.

I then tried to delete the cert by running ‘sudo certbot delete’

I now can’t get my nginx service to restart
‘nginx -t:’
root@ubuntu-512mb-sfo1-01:~# nginx -t
nginx: [warn] server name “” has suspicious symbols in /etc/nginx/sites-enabled/default:80
nginx: [warn] server name “” has suspicious symbols in /etc/nginx/sites-enabled/default:80
nginx: [warn] server name “” has suspicious symbols in /etc/nginx/sites-enabled/default:181
nginx: [warn] server name “” has suspicious symbols in /etc/nginx/sites-enabled/default:181
nginx: [emerg] BIO_new_file("/etc/letsencrypt/live/") failed (SSL: error:02001002:system library:fopen:No such file or directory:fopen(’/etc/letsencrypt/live/’,‘r’) error:2006D080:BIO routines:BIO_new_file:no such file)
nginx: configuration file /etc/nginx/nginx.conf test failed

Here is the output of my /etc/nginx/sites-available/default

I only have one config(?) that holds all information for all my websites/applications (/etc/nginx/sites-available/default)

Don’t quite know how to proceed from here.

I am a complete noob when it comes to this so I apologize in advance.

I am also open to wiping, and redeploying my server if that matters. Thank you.

My domain is:,,,

I ran this command: sudo certbot --nginx

It produced this output: ‘congrats…’

My web server is (include version): nginx version: nginx/1.10.3 (Ubuntu)

The operating system my web server runs on is (include version): Ubuntu 16.04

My hosting provider, if applicable, is: Digitalocean

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 0.31.0

Application I’m trying to deploy: Node.js / vue / nuxt apps

Hi @AmazeCPK

there is something like


That's wrong, http:// isn't a correct server_name.

Change that to



Please don't delete certificates if you don't know if you need these. That produces additional problems because your https vHosts may not longer work -> that blocks your nginx too.

Thank you @JuergenAuer
I’ve changed the servername as requested. At this stage, I am still unable to start nginx wit the same error.

Thank you for mentioning the bit about deleting the certs. I was trying to undo the process, but unfortunately it doesn’t seem it’s as easy as that

Still looking for a way to continue. Thank you!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.