Client side troubleshooting expired Sep-30 expiry

I am trying to access a website (of my hoster) who has the Letsencrypt certificate that expired on 30 September. As a result, my machine (Mac and windows running on Parallels within it) cannot access some key websites. The hoster claims that it is not their problem because they cannot "replicate" the " HTTP Error 403.16 - Forbidden - Your client certificate is either not trusted or is invalid." error.

Is there anything that I can do on my end to allow my computer to look at their website with this issue? I have tried deleting ISRG Root X1, but it obviously won't let me delete the System Root certificate. I tried uploading the latest ISRG Root X1 certificate to System in the Keychain Access (and "Always Trust" it), but this did not work.

Client certificate usually means a certificate on your own device rather than the one the server is presenting. Can you provide a sample URL?

1 Like

The URL is When I go there, I get the error " HTTP Error 403.16 - Forbidden.
Your client certificate is either not trusted or is invalid." I understand what DotNetPark could do on their server to trust my certificate, but is there anything I can do to get the DotNetPark server to trust my certificate?

I'm presented with this:

It seems that site tries to authenticate the user via certificate.
[You may not see the prompt if there is only one cert - no choice]
However, if I choose "Cancel", the site allows me to enter.

Ah! Thanks rg305. That did it. It never occurred to me that I could ignore that prompt. Thanks.


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.