Challenge failed when installing certificate

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:
aplanetbit.com

I ran this command:
sudo certbot --apach

It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache
No names were found in your configuration files. Please enter in your domain
name(s) (comma and/or space separated) (Enter 'c' to cancel): aplanetbit.com
Requesting a certificate for aplanetbit.com
Performing the following challenges:
http-01 challenge for aplanetbit.com
Enabled Apache rewrite module
Waiting for verification...
Challenge failed for domain aplanetbit.com
http-01 challenge for aplanetbit.com
Cleaning up challenges
Some challenges have failed.

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: aplanetbit.com
    Type: connection
    Detail: Fetching
    http://aplanetbit.com/.well-known/acme-challenge/q1z4XKYxNdlz3LRz-wMXCSWf0ZgI1DGGxfJ8Y-fOgpY:
    Connection refused

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you're using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

My web server is (include version):
Server version: Apache/2.4.29 (Ubuntu)

The operating system my web server runs on is (include version):

Distributor ID: Ubuntu
Description: Ubuntu 18.04.5 LTS
Release: 18.04
Codename: bionic

My hosting provider, if applicable, is:
I use an Orange PI

I can login to a root shell on my machine (yes or no, or I don't know):
yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):
no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):
certbot 1.12.0

Note: Port 80 is open in my router, so http connection is available.
Thanks in advance for your help

Hi @pedrosc1967

with my browser, I can load that url.

Looks like you have a regional firewall that blocks Letsencrypt / US-sources.

Worldwide access is required.

1 Like

It is quite strange because if I use a Raspoberry instead of a OrangePi it worked correctly and I'm quite sure it will work again.

Are there another possibilities?

I'm getting some strange results:

osiris@erazer ~ $ curl -LIv http://aplanetbit.com/.well-known/acme-challenge/q1z4XKYxNdlz3LRz-wMXCSWf0ZgI1DGGxfJ8Y-fOgpY
*   Trying 88.7.175.51:80...
* connect to 88.7.175.51 port 80 failed: No route to host
* Failed to connect to aplanetbit.com port 80: No route to host
* Closing connection 0
curl: (7) Failed to connect to aplanetbit.com port 80: No route to host
osiris@erazer ~ $ sudo traceroute -T -p 80 88.7.175.51
traceroute to 88.7.175.51 (88.7.175.51), 30 hops max, 60 byte packets
(...)
6  ae16-100-cr6-ams1.ipv4.gtt.net (194.122.122.102)  35.980 ms  15.179 ms ae11-100-cr5-ams1.ipv4.gtt.net (194.122.122.98)  15.163 ms
 7  ae3.cr1-lon8.ip4.gtt.net (213.200.118.102)  26.203 ms  55.114 ms  55.077 ms
 8  94.142.107.162 (94.142.107.162)  26.861 ms * *
 9  176.52.248.154 (176.52.248.154)  55.004 ms  54.997 ms  54.982 ms
10  213.140.51.57 (213.140.51.57)  54.951 ms  50.477 ms  40.669 ms
11  70.red-80-58-96.staticip.rima-tde.net (80.58.96.70)  45.887 ms  44.820 ms  44.818 ms
12  * * 70.red-80-58-96.staticip.rima-tde.net (80.58.96.70)  45.008 ms
13  * * *
14  51.red-88-7-175.staticip.rima-tde.net (88.7.175.51)  48.364 ms  43.825 ms  52.573 ms
15  51.red-88-7-175.staticip.rima-tde.net (88.7.175.51)  797.146 ms !H  797.141 ms !H  797.133 ms !H
osiris@erazer ~ $ 

Your own IP address is replying with "host unreachable" ICMP packets. This suggests to me some kind of active firewall on your host.

Then you know what you have to do. Fix your OrangePi - configuration.

PS: Now I have a blocked result too - looks like a blocking firewall.

1 Like

If this is a home system - not a colo server, then there may be a mismatch in the NATting.
Where the outside IP is being send to an inside IP that is no longer there.

@pedrosc1967 is there any NATting going on?
If so, has your inside IP changed?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.