Challenge failed, No valid IP addresses found

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:
I am working on Docker and I docker-compose up’d using image: linuxserver/letsencrypt

It produced this output:
Obtaining a new certificate

Performing the following challenges:

http-01 challenge for

http-01 challenge for

Waiting for verification…

Challenge failed for domain

Challenge failed for domain

http-01 challenge for

http-01 challenge for

Cleaning up challenges

Some challenges have failed.


  • The following errors were reported by the server:



Type: connection

Detail: unknownHost :: No valid IP addresses found for



Type: connection

Detail: Fetching

Timeout after connect (your server may be slow or overloaded)


To fix these errors, please make sure that your domain name was

entered correctly and the DNS A/AAAA record(s) for that domain

contain(s) the right IP address. Additionally, please check that

your computer has a publicly routable IP address and that no

firewalls are preventing the server from communicating with the

client. If you’re using the webroot plugin, you should also verify

that you are serving files from the webroot path you provided.

  • Your account credentials have been saved in your Certbot

    configuration directory at /etc/letsencrypt. You should make a

    secure backup of this folder now. This configuration directory will

    also contain certificates and private keys obtained by Certbot so

    making regular backups of this folder is ideal.

ERROR: Cert does not exist! Please see the validation error above. The issue may be due to incorrect dns or port forwarding settings. Please fix your settings and recreate the container

My web server is (include version):
Django 1.11, Nginx

The operating system my web server runs on is (include version):
Windows 10

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
Not sure

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

Hi @maykristine,

The meaning of these errors is:

(1) There is no DNS A record for the first name, There needs to be a publicly-visible DNS A or AAAA record for this name in order to get a certificate for it by this method.

(2) The second name,, does exist in DNS, but HTTP connections to this machine on port 80 seem to hang with no reply from your server. In this case, there needs to be an existing publicly-accessible HTTP service on this server in order to get a certificate for it by this method. (There might be a firewall intercepting port 80 connections from outside of your institution, for example.)

1 Like

Thanks for your response! So I tried fumbling around and used this tutorial from humankode. instead.
Last command I ran is:

docker run -it --rm
-v /docker-volumes/etc/letsencrypt:/etc/letsencrypt
-v /docker-volumes/var/lib/letsencrypt:/var/lib/letsencrypt
-v /docker/letsencrypt-docker-nginx/src/letsencrypt/letsencrypt-site:/data/letsencrypt
-v “/docker-volumes/var/log/letsencrypt:/var/log/letsencrypt”
certonly --webroot
–register-unsafely-without-email --agree-tos

My new error is:
Challenge failed for domain
http-01 challenge for
Cleaning up challenges
Some challenges have failed.


It looks like some aspect of the mapping of /data/letsencrypt to /docker/letsencrypt-docker-nginx/src/letsencrypt/letsencrypt-site (and perhaps of that directory to /usr/share/nginx/html) is not working and so nginx doesn’t end up being able to find the file that Certbot created in order to satisfy the CA challenge.

I see that your site is now serving the Oh, hai there! page that the tutorial has you create, so it looks like at least part of the process is working. If you create a file in /data/letsencrypt from the point of view of this Docker command, can you see that file served on your temporary test service?

1 Like

It already worked!!! Thank you!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.