Challenge failed for my domain during before download letsencrypt

My domain is: crystalkcave.online

I ran this command: /opt/letsencrypt/letsencrypt-auto

It produced this output: Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator nginx, Installer nginx

Which names would you like to activate HTTPS for?


1: www.crystalcave.online


Select the appropriate numbers separated by commas and/or spaces, or leave input
blank to select all options shown (Enter ‘c’ to cancel):
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for www.crystalcave.online
Waiting for verification…
Challenge failed for domain www.crystalcave.online
http-01 challenge for www.crystalcave.online
Cleaning up challenges
Some challenges have failed.

My web server is (include version): nginx

The operating system my web server runs on is (include version): Ubuntu 16

My hosting provider, if applicable, is: virtual machine on AWS

I can login to a root shell on my machine (yes or no, or I don’t know): yes, all command I ran with root

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no, I connect by SSH

I have create my vm in AWS, afterthat I registered a domain crystalcave.online on OVH where I change A records toStatic Public IP of my vm on AWS. Actually I access on my site (odoo13)

1 Like

Hi @darioconcilio

what’s your version? If your Certbot is too old -> update it.

And what’s the complete error output?

Your domain isn’t registered - https://check-your-website.server-daten.de/?q=crystalkcave.online

Host T IP-Address is auth. ∑ Queries ∑ Timeout
crystalkcave.online Name Error yes 1 0
www.crystalkcave.online Name Error yes 1 0

That’s only a local installation.

You need a registered, public visible, worldwide unique domain name.

1 Like

crystalkcave.online isn’t registered but crystalcave.online is. And the DNS looks like it’s probably valid:

crystalcave.online.      3600  A   35.181.24.17
crystalcave.online.      3600  NS  dns14.ovh.net.
crystalcave.online.      3600  NS  ns14.ovh.net.
www.crystalcave.online.  3600  A   35.181.24.17
1 Like

Domain is crystalcave.online
Record A is correct, this one is public static IP of my virtual machine on AWS
Actually I have these inbound rules activated
HTTP TCP 80 0.0.0.0/0
HTTP TCP 80 ::/0
SSH TCP 22 my local IP
ODOO TCP 8069 my local IP

1 Like

Yep, that domain is defined. The main configuration is ok, /.well-known/acme-challenge/random-filename answers with a correct http status 404 - Not Found.

So your nginx configuration may be incomplete, but it’s not a problem of your firewall.

What says

nginx -T

What’s the exact error message?

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.