CertSage 1.4.2 - cURL execution failed

My domain is: www.riversidereflexology.com (with three aliased domains - www.riverside-reflexology.com and the two .co.uk equivalents for both).

I ran this command: I used the CertSage 1.4.2 GUI

It produced this output: cURL execution failed: https://acme-v02.api.letsencrypt.org/acme/finalize/1826556117/285565910907 (and latterly, this: https://acme-v02.api.letsencrypt.org/acme/authz-v3/374481138767 and this: https://acme-v02.api.letsencrypt.org/acme/new-acct)

My web server is (include version): Apache 2.4.59

The operating system my web server runs on is (include version): Linux.

My hosting provider, if applicable, is: TSOHost

I can login to a root shell on my machine (yes or no, or I don't know): No.

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): Yes - cPanel 110.0 (build 20)

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): Unknown.

Hi there, I hope you can help. I installed CertSage 1.4.2 on my site, filled in my primary domain and password, tested via "acquire staging" option (which worked) and then tried the Production option. It failed a few times but eventually worked but only for my main domain above, not the aliases. I worked out that if I add each alias at a time it is more successful, but even then several attempts are needed and the last one just won't work at all. I have tried adding www.riversidereflexology.co.uk several times but it always fails at Production - any idea what I'm doing wrong? Probably something stupid on my part... I don't really know what I'm doing!

EDIT: It just worked after the 10th or 11th attempt - woohoo! I'd still like to know why it took so many attempts though as I guess I'll have to go through the same process in a couple of months and anything I can do to make it work smoothly first time is a good thing.

Thanks in advance for the help...

Steve

2 Likes

Welcome to the Let's Encrypt Community, @StirlingSteve! :slightly_smiling_face:

I'm the author of CertSage.

Firstly, glad you got this working!

A large portion (if not most) of CertSage is error handling, so when something like this happens, I too like to understand why. Given that I haven't seen this issue systemically (i.e. I haven't seen a number of similar reports here in the Let's Encrypt Community or via email), my initial presumption is that this is possibly related to Let's Encrypt tweaking/upgrading some things related to their service lately. If you notice further issues or have additional information to report, please do so.

Thanks. :pray:

2 Likes

Several users have complained of this in the last hour. I am investigating now. Follow https://letsencrypt.status.io/pages/incident/55957a99e800baa4470002da/668c963eafdb5f174f9f2443 for status updates.

Can you provide any more information on the periods of time when you started encountering these errors, and what IP address you used to connect?

5 Likes

Hi and thanks for the info!

2 Likes

Hi there,

Time-wise, each attempt was taking about 3 minutes to time out I would guess, but not 100% sure as I was doing other things as well in the background. I'll PM you my IP address.

Ta!

1 Like

For reference, I'm also seeing this error. Also on tsohost.

cURL execution failed: https://acme-v02.api.letsencrypt.org/acme/authz-v3/374644709447

1 Like

(also - after a few attempts it worked. It's probably just a coincidence, but I upgraded to CertSage 1.4.2 just before it worked. I think I'd previously been on 1.2.x)

1 Like

We've had some reports of network trouble from some users reaching Let's Encrypt. We saw a small dip in traffic, but it has since recovered.

Can you let us know if you're still seeing this problem after about 14:20 UTC, about 1 hour ago?

3 Likes

Yes, just tried it again and it worked fine and much faster too so I guess it could have easily been network issues for me.

Ta,

2 Likes