Certificate won't renew

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: vault.thesilentlink.duckdns.org

I ran this command: sudo certbot renew --dry-run

It produced this output:

Processing /etc/letsencrypt/renewal/vault.thesilentlink.duckdns.org.conf


Cert not due for renewal, but simulating renewal for dry run
Plugins selected: Authenticator nginx, Installer nginx
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for vault.thesilentlink.duckdns.org
Waiting for verification…
Cleaning up challenges
Attempting to renew cert (vault.thesilentlink.duckdns.org) from /etc/letsencrypt/renewal/vault.thesilentlink.duckdns.org.conf produced an unexpected error: Failed authorization procedure. vault.thesilentlink.duckdns.org (http-01): urn:ietf:params:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from https://vault.thesilentlink.duckdns.org/.well-known/acme-challenge/ABR2UbEerq1zKatQ-tCQP2Sz_8YKRwGlfM86YiuZHRQ [86.134.148.182]: “\n \n \n \n <meta charset=“utf-8”>\n <title”. Skipping.

My web server is (include version): nginx version: nginx/1.14.2

The operating system my web server runs on is (include version): Raspbian Buster

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 0.31.0

Hi this subdomain won’t get a certificate but every other subdomain works fine. Running sudo certbot --debug-challenges -v allowed me to get a certificate but it won’t renew. My nginx config is:
server {
listen 80;
server_name vault.thesilentlink.duckdns.org;
root /var/www/html/.well-known;
location /.well-known {
alias /var/www/html/.well-known;
allow all;
default_type “text/plain”;
autoindex on;
}
return 301 https://$host$request_uri;
}

server{
server_name vault.thesilentlink.duckdns.org;
listen 443;

Allow large attachments

client_max_body_size 128M;

location / {
proxy_pass http://127.0.0.1:8081;
proxy_set_header Host $host;
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_set_header X-Forwarded-Proto $scheme;
}

location /notifications/hub {
proxy_pass http://127.0.0.1:3012;
proxy_set_header Upgrade $http_upgrade;
proxy_set_header Connection “upgrade”;
}

location /notifications/hub/negotiate {
proxy_pass http://127.0.0.1:8081;
}

Optionally add extra authentication besides the AUTH_TOKEN

If you don’t want this, leave this part out

location /admin {
# See: https://docs.nginx.com/nginx/admin-guide/security-controls/configuring-http-basic-authentication/
#auth_basic “Private”;
#auth_basic_user_file /path/to/htpasswd_file;

proxy_set_header Host $host;
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_set_header X-Forwarded-Proto $scheme;

proxy_pass http://127.0.0.1:8081;

}
ssl_certificate /etc/letsencrypt/live/vault.thesilentlink.duckdns.org/fullchain.pem; # managed by Certbot
ssl_certificate_key /etc/letsencrypt/live/vault.thesilentlink.duckdns.org/privkey.pem; # managed by Certbot
}

1 Like

Hi @AnOnlineUser

there are two certificates created today. So why is your configuration now buggy?

And you use one of these certificates - https://check-your-website.server-daten.de/?q=vault.thesilentlink.duckdns.org

CN=vault.thesilentlink.duckdns.org
	28.01.2020
	27.04.2020
expires in 90 days	vault.thesilentlink.duckdns.org - 1 entry

PS: You may have two port 443 vHosts with the same domain name. Remove the not used vHost.

1 Like

Hi @JuergenAuer,
I don’t have multiple vhosts using the same domain name. It wouldn’t give me a certificate and I kept getting the error above until I used sudo certbot --debug-challenges -v. This command successfully gave me a certificate. However if I run a dry renew it fails. I assume that unless I fix this issue the certificate won’t renew in 3 months.

You have created a certificate.

Then you have changed something.

So undo that.

1 Like

I didn’t change anything. That is the config I used when I ran sudo certbot --debug-challenges -v.