Certificate with Open media Vault & Owncloud


#1

So i have asked Dr Google about installation methods and have had no luck.
I am trying generate a certificate to use for OwnCloud and Open Media Vault

I have Nginx for Owncloud

i also have full root ssh access

Please Help!!!


#2

What exactly have you tried and what exactly went wrong? More info would be much appreciated, otherwise I’m only able to point you to the documentation.


#3

Osiris is right, you didn’t really provide enough information for us to be too helpful. However I’m going to give it a shot anyway :slight_smile:

If you have full root access via ssh, that makes life much easier. I’d recommend using webroot authentication if possible. That places a small hidden temporary file in your website’s file tree so Let’s Encrypt knows you actually have control of the webserver and domain. I’d also recommend generating your certificates using “certonly” and then manually pointing your server config to the certificate and chain (the Apache and NginX plugins are not very mature yet).

The “Standalone” authentication method is not what you’re after. It requires access to ports 80 and 443, which means you have to shut the webserver down to authenticate. You don’t want to do that every time you attempt renewal, so only use it if you have to. It’s a perfect option for people running mail servers without a webserver, though.

As Osiris said, you should check out the documentation. It gives you a pretty good breakdown of the different authentication methods. I’m running ownCloud like you, but I’m using Apache 2.4, so I can’t give you any NginX config advice :stuck_out_tongue_winking_eye:

Oh, and you don’t have to use the official client. The Let’s Encrypt CA service is completely independent of which client you use, and there are many to choose from. I’d still use the official client if you can since it gets the most support in the forum, but it does have a couple of drawbacks that may stop some people being able to use it (e.g. it requires root, doesn’t yet support DNS authentication, etc).

I hope that helps! If not, come back to us with more information about your situation and I’ll have another go.


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.