Certificate renewal,try to renew wesb that are migrated to other server


#1

Hi all.

I need to renew the web certificates of my apache server, but also try to renew web that are no longer on the server and are in another showing the typical error of the configuration dns A / AAAA. How can I solve this error?

Thank you.


#2

Hi @fjsantos

  • make a backup of your /etc/letsencryt folder
  • show your certificates with certbot certificates
  • delete certificates with certbot delete certname (from the command (2))
  • renew

#3

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):


#4

Hi

It worked, thank you very much.

Now I still have the problem that it does not generate the certificate.


#5

Hi.
ipv6.zilog.es
sudo certbot --apache certonly


Apache 2, 2.4.7
Ubuntu 14.04.5 LTS
certbot 0.28.0
https://crt.sh/?q=ipv6.zilog.es


#6

Then your apache plugin doesn’t understand your configuration.

Check your vHost to find your DocumentRoot. Then use something like

certbot run certonly -a webroot -w YourDocumentRoot -d ipv6.zilog.es

#7

Yesssssss

Thnks…:slight_smile: