Certificate renewal rejected

Hi, I tried to renew the certificate that had expired a few days ago, but when requesting the new certificate the response is a error.

My domain is:
https://www.simonedangelo.it

I ran this command:
Request new certificate

It produced this output:
IMPORTANT NOTES: - The following errors were reported by the server: Domain: simonedangelo.it Type: unauthorized Detail: Invalid response from http://www.simonedangelo.it/ [80.211.73.5]: "\n\n $(function () { toastr.options = { “debug”: false, “newestOnTop”: false, “positionClass”: “toast-top-center”, “closeButton”: true, }; toastr.error(‘Error!!! Certificato Let’s Encrypt non rilasciato’); });

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:
https://www.hostingvirtuale.com

I can login to a root shell on my machine (yes or no, or I don’t know):
I don’t know

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): Yes, Hosting Virtuale Control Panel v. 2.7

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): I don’t know

1 Like

When I visit http://simonedangelo.it/test-xyz, it redirects to http://www.simonedangelo.it/.

I think to fix this issue, you should fix the redirect, so it redirects the full URL. The correct redirect location would be http://www.simonedangelo.it/test-xyz.

1 Like

I’m guessing you have a shared hosting plan, i.e., you don’t have “your own” server, virtual or otherwise. In that case there is very, very little you (and we) can do about this error. I believe you should contact your hosting providers support and present them with this issue.

@_az I have a feeling @simone isn’t very comfortable or able editing redirects… Could be a Wordpress redirect, perhaps in a .htaccess, perhaps configured in Wordpress itself or perhaps on a server level? I don’t know…

1 Like

I would guess it’s a WordPress redirect, maybe by a plugin, because of the response header:

X-Powered-By: PHP/7.3.7

If it was something in .htaccess or at the server level, I don’t think we’d see that header.

3 Likes

True true! Didn’t pay attention to those headers to be honest. That could be something @simone could check in her Wordpress Admin I guess.

2 Likes

Hi guys! Reading your comments I entered the WP backend because I actually had a redirect plugin. I deactivated the plugin and while I was there I updated WP to the latest version. Having a multisite installation I noticed that there was a message that the SSL certificates had to be set up on the whole network, so I changed the item of a drop-down, I saved, reloaded the page and everything broke: the sit URL sends me back to the Control Panel login and /wp-admin to a 404 page. A tsunami!
I contacted hosting support to see how to fix. In the meantime, thanks for the answers! :slight_smile:

1 Like

There’s currently a HTTP to HTTPS redirect in place without a valid certificate present. You might unblock your site by not redirecting to HTTPS at this moment. Not until you have a valid certificate that is.

1 Like

My hosting provider solved the problem. They say there was a problem in the htaccess which denied automatic renewal, but now it is OK. Thanks again! :slight_smile:

2 Likes