Certificate renewal failing with HTTP 200

My domain is: seven.dorksville.net

I ran this command: # ./certbot-auto renew

It produced this output:

Saving debug log to /var/log/letsencrypt/letsencrypt.log

Processing /etc/letsencrypt/renewal/seven.dorksville.net.conf

Cert is due for renewal, auto-renewing…
Plugins selected: Authenticator webroot, Installer None
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for seven.dorksville.net
Waiting for verification…
Challenge failed for domain seven.dorksville.net
http-01 challenge for seven.dorksville.net
Cleaning up challenges
Attempting to renew cert (seven.dorksville.net) from /etc/letsencrypt/renewal/seven.dorksville.net.conf produced an unexpected error: Some challenges have failed… Skipping.
All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/seven.dorksville.net/fullchain.pem (failure)

All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/seven.dorksville.net/fullchain.pem (failure)

1 renew failure(s), 0 parse failure(s)


  • The following errors were reported by the server:

    Domain: seven.dorksville.net
    Type: connection
    Detail: During secondary validation: Fetching
    Timeout during connect (likely firewall problem)

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

My web server is (include version): Apache 2.2 (Centos 6)

The operating system my web server runs on is (include version): Centos 6

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 1.3.0

I can see from the logs I’m getting a HTTP 200 response - - [04/Apr/2020:21:10:44 +1000] “GET /.well-known/acme-challenge/ap3Vr94wX8ZUgtsvFG8B8aG7odoRCuC1TgmB5LnDDO0 HTTP/1.1” 200 87

One, yes. That’s from the primary validation authority.

There are 3 other secondary VAs that send requests. Please review this: ACME v1/v2: Validating challenges from multiple network vantage points

2 out of 3 of the secondary VAs must succeed to get a response as well. Currently, they are all hosted on all different AWS regions - so if you are blocking, or have any network issues receiving traffic from AWS, issuance will fail.

1 Like

Thanks, I had tried shutting down my filters (but was perhaps tripped up by an automated Firewall restart)

All working now :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.