Certificate issued to my router/ISP instead of my domain?


#1

Hello everyone, I am installing a small nextcloud instance at home, for personal use. When I create the certificate with certbot, everything runs smoothly, but when I then try to access the website, I have a big error. Seems like the certificate has been issued to my router/ISP (vodafone), instead of my domain… it never happened before to me. Got any idea on how to fix it?

Here are all the details, thanks a lot!

My domain is: cloud.arteteco.com

I ran this command: certbot --nginx -d cloud.arteteco.com

It produced this output: Congratulations! You have successfully enabled https://cloud.arteteco.com

My web server is (include version): nginx 1.10.3

The operating system my web server runs on is (include version): debian 9

My hosting provider, if applicable, is: self hosted

I can login to a root shell on my machine: yes

I’m using a control panel to manage my site : no


#2

Works fine for me.

Maybe it’s a NAT/router issue, where you only have a problem when visiting from inside your own network.

If you visit the domain using e.g. your smartphone’s cellular connection, you should see that it works OK.

I believe you should be able to configure your router’s NAT in “hairpin”/“reflected” mode so you can access the domain properly.


#3

Hi @beleriandcrises

same here: All looks good.

You have a correct redirect http -> https, your certificate has the correct domain name, created yesterday, valide 90 days.

If you use your site with a certificate, you must use your domain name, not your ip address. With ip address, the certificate would be invalide.


#4

crivens, you are right! From the outside it works perfectly… I have to have the talk with the router. Thanks for your time =)

Thanks @JuergenAuer too for your help, I guess this can be considered solved now


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.