Certificate for mumble server


I would like to make a certificate for a mumble server, however, I am not sure how to do that. I used a tutorial to get the certificate for my webpage, so I have no idea how certbot works. If you could help me, that would be great :slight_smile:

My domain is: Deletecat.com

I ran this command: certbot --authenticator webroot --installer apache

With that command, I got the certificate for my website.

My web server is (include version): Apache2

The operating system my web server runs on is (include version): Debian 9

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 0.28.0

1 Like

Hi @deletecat

please use the mumble wiki. There are a lot of informations how to create or import a certificate. Create a certificate via Certbot, then import it.


I ran certbot -d and it made the certificate, I proceded to connect it to mumble.
Thank you for your help!

1 Like

You should verify that certbot has a working scheduled renewal job.
You could also try an unattended test renewal manually (certbot renew -q --dry-run) to be sure it will work when the time comes.
And also keep it up to date with the latest version available (not sure what that is for Deb9).

1 Like

I tried running the command with root, however, it came up with an error saying that the client lacks sufficient authorization. But the only renew error was for deletecat.com, not for anything else. Is there anyway to fix this? Thanks

I don’t see something to fix. Checking your domain there is a new certificate - https://check-your-website.server-daten.de/?q=deletecat.com#ct-logs

Issuer not before not after Domain names LE-Duplicate next LE
Let’s Encrypt Authority X3 2019-11-01 2020-01-30 mumble.deletecat.com - 1 entries duplicate nr. 1

Where is that certificate?

What says

certbot certificates

Use that certificate and upload it. Then it should be done.

Only problem: Looks like the last part doesn’t allow automation. So you have to do that every 60 - 85 days manual.

1 Like

I removed my last post because I found the source of the problem, it was a setting in the apache2 config file.

If ‘Require all granted’ is ‘Require all denied’, it means people can’t look at the www directory, I had it set to denied. Which then messed up certbot when I was doing a test run. I changed the setting to granted and it seemed to have worked with no errors. Thank you for your suggestions :slight_smile:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.