Certificate expired too soon without warning

Hi,
I’m running two Synology server and use Let’s Encrypt for both of them.
They have each one certificate with few aliases: nas01.spiroux.be and nas02.spiroux.be .

On the 26 september 2019 the certificate for my nas02 wasn’t valid anymore, so I wasn’t able to connect by VPN nor the webinterface without warning from Firefox/Chrome or anything.
I tought that I missed a mail and renewed the certificate.
I noticed that in the webinterface of the server it was still see as valid certificate, till 24 december 2019.

Then on the 06 november 2019 the certificate wasn’t trusted anymore.

So I would like to know what is happening? Why my certificate are revoked after only 2 weeks?
But, the certificate on the server 01 don’t have any issue.

My domain is: nas02.spiroux.be; nas02-bk.spiroux.be
My web server is (include version): don’t have any
The operating system my web server runs on is (include version): Synology DSM 6.2.2
My hosting provider, if applicable, is: OVH
I can login to a root shell on my machine (yes or no, or I don’t know): Yes
I’m using a control panel to manage my site (no, or provide the name and version of the control panel): Yes, DSM 6.2.2

EDIT: For information, no port are opened from the WAN to my server. I’m only connecting by VPN and open 80/443 when I’m renewing the cert.
I do the same with the first server and have no issues.

Hi @SaltySpi

that’s a known bug of the Synology Letsencrypt client.

Check

Hi @JuergenAuer

Thank you for your fast reply.
I did a full replace today when I solved the issue as they propose in your link.

So it should be solved.
Wait and see!

Regards!

1 Like