Certificate appears as outdated, however it is up to date


#1

Hello, first of all I would like to thank all of you for your help. This is my first post in Let’sEncrypt.
The point is that my certificate has been working well until now. It is valid until next 26/Jul/2018, however when I try to acces to my APP it appears to be outdated.
I have checked on this website https://www.digicert.com/help/ and it seems as my certificate was outdated since last 17/Apr/2018.
When I run “certbot renew” on my server the certificate is up to date. I forced the renew and the expires date changed from june to july but when I try to acces to my my app, the certificate continues appearing as outdated since april.
My app is running on Amazon AWS on an Ubuntu server and it has been working well for last months.

What’s wrong?

Thank you very much!


#2

Is your webserver configured to use the certificate files in /etc/letsencrypt/live/...? Those are the ones that are automatically updated (actually they’re symbolic links to the latest versions).

If so, did you reload your web server after renewing the certificate? This may or may not be necessary depending on exactly how you got the certificate originally. If this is the problem, you can make the renew command automatically reload your webserver by using the --deploy-hook option, e.g. certbot renew --deploy-hook "service apache2 reload" - after this succeeds once, it will be remembered (for that certificate) for next time you run certbot renew.


#3

Thank you jmorahan.
I just solved it. The problem was that I was referencing to a local folder instead of /etc/letsencrypt/live/
It was my mistake :smile:

Thanks!


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.