Certbot successfully deployed certificates but fails letsdebug

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: cherrysequence.net / www.cherrysequence.net

I ran this command: sudo certbot --nginx

It produced this output:

Successfully received certificate.
Certificate is saved at: /etc/letsencrypt/live/cherrysequence.net/fullchain.pem
Key is saved at: /etc/letsencrypt/live/cherrysequence.net/privkey.pem
This certificate expires on 2022-05-10.
These files will be updated when the certificate renews.
Certbot has set up a scheduled task to automatically renew this certificate in the background.

Deploying certificate
Successfully deployed certificate for cherrysequence.net to /etc/nginx/sites-enabled/cherry
Successfully deployed certificate for www.cherrysequence.net to /etc/nginx/sites-enabled/cherry
Congratulations! You have successfully enabled HTTPS on https://cherrysequence.net and https://www.cherrysequence.net

My web server is (include version): Vultr VPS

The operating system my web server runs on is (include version): Debian 10

My hosting provider, if applicable, is: Vultr

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): 1.23.0

This is strange, when I saw port 80 not working I assumed you used --standalone.

Certbot probably added a temporary config to nginx. I wouldn't worry about it. If you want to make Let's Debug appy, enable an http2https redirect with certbot enhance --redirect.

1 Like

Hi. Thanks for your response. I tried this, and now my website is not returning ping on either cherrysequence.net or www.cherrysequence.net

Any advice?

If it's not returning ping it's either

  1. turned off,
  2. your firewall interfering, or
  3. a wrong A / AAAA dns record.

Excuse me. The www. url is not returning ping. The cherrysequence.net url is returning ping.

there is no A record for www.

(and neither an AAAA: how the hell did you get a certificate, using a dns-01 challenge?)

1 Like

I think this is because ports were closed on my VPS. Please feel free to close this thread. Many thanks for the help.

1 Like

That wouldn't interfere with your DNS records. Check that you have at least an A record for both and an AAAA if you have ipv6 support.

(AAAA alone is a possibility too if you have ipv6 support only)

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.