Certbot OS X 10.8.5 Apache install openssl error


#1

Please fill out the fields below so we can you better.

My domain is:

expat.dyndns.org

I ran this command:

sudo ./certbot-auto --debug

It produced this output:

while running apachectl configtest.
Syntax error on line 9 of /etc/letsencrypt/options-ssl-apache.conf:This version of openssl does not support configuring compression within sections.

My operating system is (include version):

OS X 10.8.5

My web server is (include version):

bash-3.2$ apachectl -V
Server version: Apache/2.2.29 (Unix)
Server built: Mar 19 2015 13:38:13
Server’s Module Magic Number: 20051115:36
Server loaded: APR 1.4.5, APR-Util 1.3.12
Compiled using: APR 1.4.5, APR-Util 1.3.12
Architecture: 64-bit
Server MPM: Prefork
threaded: no
forked: yes (variable process count)
Server compiled with…
-D APACHE_MPM_DIR=“server/mpm/prefork”
-D APR_HAS_SENDFILE
-D APR_HAS_MMAP
-D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
-D APR_USE_FLOCK_SERIALIZE
-D APR_USE_PTHREAD_SERIALIZE
-D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
-D APR_HAS_OTHER_CHILD
-D AP_HAVE_RELIABLE_PIPED_LOGS
-D DYNAMIC_MODULE_LIMIT=128
-D HTTPD_ROOT="/usr"
-D SUEXEC_BIN="/usr/bin/suexec"
-D DEFAULT_PIDLOG="/private/var/run/httpd.pid"
-D DEFAULT_SCOREBOARD=“logs/apache_runtime_status”
-D DEFAULT_LOCKFILE="/private/var/run/accept.lock"
-D DEFAULT_ERRORLOG=“logs/error_log”
-D AP_TYPES_CONFIG_FILE="/private/etc/apache2/mime.types"
-D SERVER_CONFIG_FILE="/private/etc/apache2/httpd.conf"

My hosting provider, if applicable, is:

me

I can login to a root shell on my machine (yes or no, or I don’t know):

yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

no

Other details -

I am using macports, and using the Apple default Apache 2 webserver and have configured it with a self signed certificate before.

Any idea what might be causing the problem with certbot?


#2

Anyway, I worked out how to fix it.

I went into

/etc/letsencrypt/options-ssl-apache.conf

and commented out the following line:

SSLCompression off

Then certbot worked as expected.


#3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.