Certbot oracle linux configuration with google domains

My domain is: stockbettor.com

I ran this command: sudo /usr/local/bin/certbot-auto certonly --standalone
It produced this output: No valid IP addresses found for stockbettor.com
or alternatively ip address in not valid website

My web server is (include version): node v 14

The operating system my web server runs on is (include version): linux redhat oracle cloud free tier

My hosting provider, if applicable, is: Oracle Cloud

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): 1.3.0

I am using google domains for my domain name and I cannot get certbot to recognize the domain

1 Like

Hi @velociwabbit

that's expected, your configuration is buggy - see https://check-your-website.server-daten.de/?q=stockbettor.com

You have a Grade L - a loop:

Loop - it's impossible to use this site

So Letsencrypt can't check your domain.

1 Like

Thank you for the very quick reply.

Not sure what i a loop means... right now i do not have a webserver running because i have been trying to use certbot to generate a certificate.

What would cause a loop?


I think i might see the problem... in google domains If i have an A record for the ip address then a redirect will not be required? Right now i have both?

See your check result:

Domainname Http-Status redirect Sec. G
http://stockbettor.com/ 302 http://stockbettor.com Html is minified: 101,39 % 0.060 D
http://stockbettor.com/ 302 http://stockbettor.com Html is minified: 101,39 % 0.060 D

Redirect -> next redirect -->> Loop.

There runs a webserver.

1 Like

A working port 80 / http webserver is required to use http validation.

So that

404. That’s an error.

The requested URL / was not found on this server. That’s all we know.

can't work if you want to create a certificate. First - webserver, second - certificate.

1 Like

ok thanks... a bit of chicken and egg for me... i cant run my node server in google cloud at port 80 ... but i have a lead which is better than i had before ... thanks


It fixed it.

For those who are on google domains... you must have an a record (using only the @ sign) and you cannot redirect to your ip address it must be a dns record (there are two sections on google one for redirection the other for dns records)


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.