Certbot not running after adding www certificate

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: htfsoftware.com

I ran this command: certbot renew --dry-run

It produced this output: none

My web server is (include version): Nginx 1.25.3

The operating system my web server runs on is (include version): Amazon Linux 2

My hosting provider, if applicable, is: AWS

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

I obtained a cert for htfsoftware.com using --dns-route53 and all was working fine. Then I got a cert for www.htfsoftware.com and certbot no longer works at all. Runniing certbot renew --dry-run returns nothing and there is nothing in the log. Even certbot --version returns nothing. Which certbot returns /bin/certbot and there is a certbot link and certbot-2 in /bin. I've tried restarting the server instance. Any ideas much appreciated.

Hi @lblake, and welcome to the LE community forum :slight_smile:

It sounds like certbot was either removed or overwriten.
What shows?:

  • which certbot
  • find / -name certbot
2 Likes

Which certbot returns /bin/certbot and there is a certbot sym link to certbot-2 and certbot-2 in /bin.

Seems the binary got corrupted somehow. I copied the certbot binary from an installation on another server instance and it works now. Be nice to know how it got corrupted.

Certbot is written in Python and thus is not a binary :slight_smile:

It's also very strange to have a certbot-2 file.

2 Likes

Good to know. I am not that familiar. If certbot-2 is not usual might be something there.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.