Certbot Not Renewing 1 of 2 domains Openlitespeed

My domain is: franchise-uk.co.uk / www.franchise-uk.co.uk

I ran this command: certbot renew

It produced this output:
franchise-uk.co.uk not due for renewal yet
uk-franchises-for-sale.co.uk DNS not exist (no longer required anway so removed A records)

My web server is (include version): Ubuntu

The operating system my web server runs on is (include version): Openlitespeed

I can login to a root shell on my machine (yes or no, or I don't know): Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): Web Admin Openlitespeed

In Google Chrome, my domain "franchise-uk.co.uk" says expires in 5 days.
But when I try to renew, it says franchise-uk.co.uk isnt due for renewal and instead its actually uk-franchises-for-sale.co.uk which is due for renewal , but the certificate still exists despite me removing domain and dns records.

I ran certbot certificates and this is what it shows:

Found the following certs:
  Certificate Name: franchise-uk.co.uk
    Domains: franchise-uk.co.uk www.franchise-uk.co.uk
    Expiry Date: 2021-04-18 08:32:42+00:00 (VALID: 65 days)
    Certificate Path: /etc/letsencrypt/live/franchise-uk.co.uk/fullchain.pem
    Private Key Path: /etc/letsencrypt/live/franchise-uk.co.uk/privkey.pem
  Certificate Name: uk-franchises-for-sale.co.uk
    Domains: uk-franchises-for-sale.co.uk www.uk-franchises-for-sale.co.uk
    Expiry Date: 2021-02-16 12:23:01+00:00 (VALID: 5 days)
    Certificate Path: /etc/letsencrypt/live/uk-franchises-for-sale.co.uk/fullchain.pem
    Private Key Path: /etc/letsencrypt/live/uk-franchises-for-sale.co.uk/privkey.pem

It looks like franchise-uk.co.uk auto renewed which is great, but how do I ensure that I dont have any issues when my certificate expires for uk-franchises-for-sale.co.uk?

I assume maybe I need to remove uk-franchises-for-sale.co.uk and make sure that franchise-uk.co.uk is the certificate used, but how do I ensure that the 65 day one is reflected without bringing the site down?
Browser seems to be using my domain franchise-uk.co.uk with the expiring certificate (for a nonexistant domain now)

Thankyou

----EDIT----

I've just restarted LSWS and it now reflects the new date (April), although Issued By shows R3 now rather than letsencrypt , can I assume that this is now solved?

Hi @mburdett555

R3 is the new Letsencrypt intermediate certificate, so that's ok.

Certbot has a delete command, see

Use that to delete the not longer needed / used certificate.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.