Certbot not able to renew on laravel site

(post has been removed)

1 Like

Hi @certbotfan, and welcome to the LE community forum :slight_smile:

Notice the HTTP-01 authentication method has failed via HTTPS.
This means that the HTTP requests have been heard and redirected.
You should look for where HTTP is being handled and ... either:

  • change it to properly handle the ACME challenge request
  • stop the HTTP service and run certbot in --standalone mode

What about option 2:

  • stop the HTTP service and run certbot in --standalone mode

Another option is to just make sure the --webroot path matches what your HTTPS webserver is using.

It's not ideal to redirect the challenge from HTTP to HTTPS but it is supported by Let's Encrypt.

Can you post the contents of this file:


Is this still the same as stated by the root folder in the nginx server block for this domain that has a listen 443 ssl;

I don't know how Laravel interacts with nginx but this should still be the same


Oh, that's the key info I was asking for.

So, the --webroot-path in that renewal config file should be this value instead

Normally we issue a certbot command to change that but I am not sure how that works given your command starts with sudo site return.ampare.shop ...

You could very carefully manually edit the renewal conf file and replace the path in both places with this folder value in the root setting

Make a backup of that conf file first. Be very careful to follow the existing syntax


But we don't even know if that method works.


SUCCESS! Thank you so much @MikeMcQ and @rg305.

I made a backup of the conf file and made the edits to the paths in both places. Now it ALL makes sense why the cert renewal was failing! Thanks again and cheers to this great community


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.