Certbot + NGINX + Windows

Following the pictures sent, it seems that the Port80 is free, right?
However Cerbot doesn't work, same error for the first Post.

Just reminding something here, my Windows 2019 is a Azure VPS, here how I configured my Networking:

I don't know, but maybe there is something that I need to configure on the Portal to allow Cerbot, does someone know anything about that?

The Azure network settings look correct. Did you open the Windows Firewall for port 80 and port 443 as well? By default that will be blocking, which would in turn cause the "Timeout during connect" error you are seeing.


I also tried with win-acme:

Firewall Ports seems to be OK

Yeah you've gone off on a different path there, DNS validation is different (certbot can do DNS validation too). The app I develop (Certify The Web) has way more supported DNS providers than either of those though, anyway that's a digression.

The firewall rule you are looking at will be specific to a certain process, you need to create a broader one just for TCP port 80 and port 443 (inbound).


I'm very embarrassed now. So sorry for taking the time you both. It seems the problem was the local firewall rules.

Thank you so much for the support!


Cool, glad you got it working :slight_smile:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.