Certbot fails to verify my domain, but I can access the challenge


#1

My domain is: comments.leotindall.com

I ran this command: certbot and certbot --manual --installer nginx

It produced this output:

My web server is (include version): nginx/1.14.0 (Ubuntu)

The operating system my web server runs on is (include version): Ubuntu 18.04.1

My hosting provider, if applicable, is: linode

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The verification process fails with a 404 error despite the fact that I can access the file it’s looking for perfectly fine from a browser or from the command line. This happens consistently and I keep getting rate limited trying to fix it. I’ve used Certbot to issue certs from this same machine for leotindall.com, vid.leotindall.com, pad.leotindall.com, and several more.


#2

You were able to wget the file over IPv4, but does IPv6 work too?

I haven’t tried the challenge URL, but http://comments.leotindall.com/ itself returns a 404 Not Found error when accessed over IPv6 and a “Home | Leo Tindall” page when accessed over IPv4.

Check Nginx’s listen and server_name directives.


#4

This does seem to have been the problem, thank you!