CERTBOT Fails due to no IPV6

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: cryptodan.net

I ran this command: sudo certbot --apache -d cryptodan.net -d imap.cryptodan.net -d smtp.cryptodan.net -d mail.cryptodan.net -d www.cryptodan.net

It produced this output: It errored out due to no AAAA for imap, smtp

My web server is (include version): Apache 2.4

The operating system my web server runs on is (include version): Ubuntu 26.04

My hosting provider, if applicable, is: Self

I can login to a root shell on my machine (yes or no, or I don't know): Yes I own the machine and have physical access

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): NA

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): Latest version

Can you post the exact error message? Not having an AAAA record is fine, as long as your DNS server is correctly reporting that there isn't one, rather than giving an error.

Please give the exact version number you're using by running certbot --version; there are lots of ways of installing certbot, so the latest one offered by the way you installed it might not be the latest one that other people are seeing.

You may also want to double-check your DNS server setup. DNSViz reports that ns2.cryptodan.ne doesn't seem to be set up correctly. I'm guessing there's a typo in some configuration (either at your registrar, or your own zone) and it's supposed to end in .net instead?

Here is the full error:

2026-08-27 14:25:07,880:INFO:certbot._internal.auth_handler:Challenge failed for domain imap.cryptodan.net
2026-08-27 14:25:07,881:INFO:certbot._internal.auth_handler:http-01 challenge for smtp.cryptodan.net
2026-08-27 14:25:07,881:INFO:certbot._internal.auth_handler:http-01 challenge for www.cryptodan.net
2026-08-27 14:25:07,881:INFO:certbot._internal.auth_handler:http-01 challenge for imap.cryptodan.net
2026-08-27 14:25:07,883:DEBUG:certbot._internal.display.obj:Notifying user:
Certbot failed to authenticate some domains (authenticator: apache). The Certificate Authority reported these problems:
Domain: imap.cryptodan.net
Type: connection
Detail: 74.104.34.195: Fetching http://imap.cryptodan.net/.well-known/acme-challenge/-I2IzyZvkY8aIAu6Uur0Hmy5cKxnsoRjDjl9FrxC3Oo: Timeout during connect (likely firewall problem)

Domain: smtp.cryptodan.net
Type: dns
Detail: DNS problem: NXDOMAIN looking up A for smtp.cryptodan.net - check that a DNS record exists for this domain; DNS problem: NXDOMAIN looking up AAAA for smtp.cryptodan.net - check that a DNS record exists for this domain

Domain: www.cryptodan.net
Type: dns
Detail: DNS problem: SERVFAIL looking up A for www.cryptodan.net - the domain's nameservers may be malfunctioning; DNS problem: SERVFAIL looking up AAAA for www.cryptodan.net - the domain's nameservers may be malfunctioning

Thanks for the error messages.

That typically means that you've not forwarded/allowed TCP port 80 to the server.

That means that you need to add A or AAAA records for smtp.cryptodan.net to your DNS server.

That's because www.cryptodan.net is CNAME'd to itself, you might want to alias it to the root instead (cryptodan.net. or @).