# Certbot failed to authenticate some domains

**URL:** https://community.letsencrypt.org/t/certbot-failed-to-authenticate-some-domains/207200
**Category:** Help
**Created:** [October 24, 2023, 1:28pm UTC](https://community.letsencrypt.org/t/certbot-failed-to-authenticate-some-domains/207200 "2023-10-24T13:28:53Z")
**Posts on this page:** 8
**Page:** 1

<div class="post-metadata">

### Author: ![airband](https://avatars.discourse-cdn.com/v4/letter/a/90db22/32.png) [@airband](https://community.letsencrypt.org/u/airband)
#### Post date: [October 24, 2023, 1:28pm UTC](https://community.letsencrypt.org/t/certbot-failed-to-authenticate-some-domains/207200/1 "2023-10-24T13:28:53Z")

</div>

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. [crt.sh | example.com](https://crt.sh/?q=example.com)), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: [netbox.air-band.net](http://netbox.air-band.net)

I ran this command: certbot --nginx -v

It produced this output:  
Saving debug log to /var/log/letsencrypt/letsencrypt.log  
Plugins selected: Authenticator nginx, Installer nginx

Which names would you like to activate HTTPS for?  
We recommend selecting either all domains, or all domains in a VirtualHost/server block.

* * *

1: [netbox.air-band.net](http://netbox.air-band.net)

* * *

Select the appropriate numbers separated by commas and/or spaces, or leave input  
blank to select all options shown (Enter 'c' to cancel): 1  
Requesting a certificate for [netbox.air-band.net](http://netbox.air-band.net)  
Performing the following challenges:  
http-01 challenge for [netbox.air-band.net](http://netbox.air-band.net)  
Waiting for verification...  
Challenge failed for domain [netbox.air-band.net](http://netbox.air-band.net)  
http-01 challenge for [netbox.air-band.net](http://netbox.air-band.net)

Certbot failed to authenticate some domains (authenticator: nginx). The Certificate Authority reported these problems:  
Domain: [netbox.air-band.net](http://netbox.air-band.net)  
Type: unauthorized  
Detail: 185.214.220.2: Invalid response from [https://netbox.air-band.net/.well-known/acme-challenge/f3CDXk5UnH1jVUwJKsdX9JGv48gtXikrbAr9V-INPSc:](https://netbox.air-band.net/.well-known/acme-challenge/f3CDXk5UnH1jVUwJKsdX9JGv48gtXikrbAr9V-INPSc:) 404

Hint: The Certificate Authority failed to verify the temporary nginx configuration changes made by Certbot. Ensure the listed domains point to this nginx server and that it is accessible from the internet.

Cleaning up challenges  
Some challenges have failed.  
Ask for help or search for solutions at [https://community.letsencrypt.org](https://community.letsencrypt.org). See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details.

My web server is (include version): nginx version: nginx/1.18.0 (Ubuntu)

The operating system my web server runs on is (include version): Ubuntu 22.04.3 LTS

My hosting provider, if applicable, is: N/A

I can login to a root shell on my machine (yes or no, or I don't know): Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):  
No

The version of my client is (e.g. output of `certbot --version` or `certbot-auto --version` if you're using Certbot): certbot 2.7.2

I have checked with the let's debug and all 3 tests pass so I'm at a loss as to why this is not working.

---

<div class="post-metadata">

### Author: ![MikeMcQ](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/mikemcq/32/52772_2.png) [@MikeMcQ](https://community.letsencrypt.org/u/MikeMcQ)
#### Post date: [October 24, 2023, 2:08pm UTC](https://community.letsencrypt.org/t/certbot-failed-to-authenticate-some-domains/207200/2 "2023-10-24T14:08:53Z")

</div>

First, I see you have been getting certs from ZeroSSL for the past year. Did you use this same Certbot setup to get those certs?

---

<div class="post-metadata">

### Author: ![airband](https://avatars.discourse-cdn.com/v4/letter/a/90db22/32.png) [@airband](https://community.letsencrypt.org/u/airband)
#### Post date: [October 24, 2023, 2:15pm UTC](https://community.letsencrypt.org/t/certbot-failed-to-authenticate-some-domains/207200/3 "2023-10-24T14:15:18Z")

</div>

Hello Mike,

No I didn't use certbot, I've been doing them manually every 3 months, hence trying to use certbot and lets encrypt today.

---

<div class="post-metadata">

### Author: ![MikeMcQ](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/mikemcq/32/52772_2.png) [@MikeMcQ](https://community.letsencrypt.org/u/MikeMcQ)
#### Post date: [October 24, 2023, 2:20pm UTC](https://community.letsencrypt.org/t/certbot-failed-to-authenticate-some-domains/207200/4 "2023-10-24T14:20:03Z")

</div>

Okay, it's a fresh start then. Thanks. The --nginx plugin usually works very well. But, sometimes odd settings in nginx config can cause trouble.

Can you upload the `config.txt` file that results from below command? If you can't upload then paste its contents but add 3 backticks before and after like shown

```plaintext
sudo nginx -T >config.txt 2>&1

```

A capital T is essential. The file should be large

If pasting, 3 backticks like  
```  
contents  
```

---

<div class="post-metadata">

### Author: ![airband](https://avatars.discourse-cdn.com/v4/letter/a/90db22/32.png) [@airband](https://community.letsencrypt.org/u/airband)
#### Post date: [October 24, 2023, 2:26pm UTC](https://community.letsencrypt.org/t/certbot-failed-to-authenticate-some-domains/207200/5 "2023-10-24T14:26:56Z")

</div>

```plaintext
nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
nginx: configuration file /etc/nginx/nginx.conf test is successful
# configuration file /etc/nginx/nginx.conf:
user www-data;
worker_processes auto;
pid /run/nginx.pid;
include /etc/nginx/modules-enabled/*.conf;

events {
        worker_connections 768;
        # multi_accept on;
}

http {

        ##
        # Basic Settings
        ##

        sendfile on;
        tcp_nopush on;
        types_hash_max_size 2048;
        # server_tokens off;

        # server_names_hash_bucket_size 64;
        # server_name_in_redirect off;

        include /etc/nginx/mime.types;
        default_type application/octet-stream;

        ##
        # SSL Settings
        ##

        ssl_protocols TLSv1 TLSv1.1 TLSv1.2 TLSv1.3; # Dropping SSLv3, ref: POODLE
        ssl_prefer_server_ciphers on;

        ##
        # Logging Settings
        ##

        access_log /var/log/nginx/access.log;
        error_log /var/log/nginx/error.log;

        ##
        # Gzip Settings
        ##

        gzip on;

        # gzip_vary on;
        # gzip_proxied any;
        # gzip_comp_level 6;
        # gzip_buffers 16 8k;
        # gzip_http_version 1.1;
        # gzip_types text/plain text/css application/json application/javascript text/xml application/xml application/xml+rss text/javascript;

        ##
        # Virtual Host Configs
        ##

        include /etc/nginx/conf.d/*.conf;
        include /etc/nginx/sites-enabled/*;
}

#mail {
# # See sample authentication script at:
# # http://wiki.nginx.org/ImapAuthenticateWithApachePhpScript
#
# # auth_http localhost/auth.php;
# # pop3_capabilities "TOP" "USER";
# # imap_capabilities "IMAP4rev1" "UIDPLUS";
#
# server {
# listen localhost:110;
# protocol pop3;
# proxy on;
# }
#
# server {
# listen localhost:143;
# protocol imap;
# proxy on;
# }
#}

# configuration file /etc/nginx/modules-enabled/50-mod-http-geoip2.conf:
load_module modules/ngx_http_geoip2_module.so;

# configuration file /etc/nginx/modules-enabled/50-mod-http-image-filter.conf:
load_module modules/ngx_http_image_filter_module.so;

# configuration file /etc/nginx/modules-enabled/50-mod-http-xslt-filter.conf:
load_module modules/ngx_http_xslt_filter_module.so;

# configuration file /etc/nginx/modules-enabled/50-mod-mail.conf:
load_module modules/ngx_mail_module.so;

# configuration file /etc/nginx/modules-enabled/50-mod-stream.conf:
load_module modules/ngx_stream_module.so;

# configuration file /etc/nginx/modules-enabled/70-mod-stream-geoip2.conf:
load_module modules/ngx_stream_geoip2_module.so;

# configuration file /etc/nginx/mime.types:

types {
    text/html html htm shtml;
    text/css css;
    text/xml xml;
    image/gif gif;
    image/jpeg jpeg jpg;
    application/javascript js;
    application/atom+xml atom;
    application/rss+xml rss;

    text/mathml mml;
    text/plain txt;
    text/vnd.sun.j2me.app-descriptor jad;
    text/vnd.wap.wml wml;
    text/x-component htc;

    image/png png;
    image/tiff tif tiff;
    image/vnd.wap.wbmp wbmp;
    image/x-icon ico;
    image/x-jng jng;
    image/x-ms-bmp bmp;
    image/svg+xml svg svgz;
    image/webp webp;

    application/font-woff woff;
    application/java-archive jar war ear;
    application/json json;
    application/mac-binhex40 hqx;
    application/msword doc;
    application/pdf pdf;
    application/postscript ps eps ai;
    application/rtf rtf;
    application/vnd.apple.mpegurl m3u8;
    application/vnd.ms-excel xls;
    application/vnd.ms-fontobject eot;
    application/vnd.ms-powerpoint ppt;
    application/vnd.wap.wmlc wmlc;
    application/vnd.google-earth.kml+xml kml;
    application/vnd.google-earth.kmz kmz;
    application/x-7z-compressed 7z;
    application/x-cocoa cco;
    application/x-java-archive-diff jardiff;
    application/x-java-jnlp-file jnlp;
    application/x-makeself run;
    application/x-perl pl pm;
    application/x-pilot prc pdb;
    application/x-rar-compressed rar;
    application/x-redhat-package-manager rpm;
    application/x-sea sea;
    application/x-shockwave-flash swf;
    application/x-stuffit sit;
    application/x-tcl tcl tk;
    application/x-x509-ca-cert der pem crt;
    application/x-xpinstall xpi;
    application/xhtml+xml xhtml;
    application/xspf+xml xspf;
    application/zip zip;

    application/octet-stream bin exe dll;
    application/octet-stream deb;
    application/octet-stream dmg;
    application/octet-stream iso img;
    application/octet-stream msi msp msm;

    application/vnd.openxmlformats-officedocument.wordprocessingml.document docx;
    application/vnd.openxmlformats-officedocument.spreadsheetml.sheet xlsx;
    application/vnd.openxmlformats-officedocument.presentationml.presentation pptx;

    audio/midi mid midi kar;
    audio/mpeg mp3;
    audio/ogg ogg;
    audio/x-m4a m4a;
    audio/x-realaudio ra;

    video/3gpp 3gpp 3gp;
    video/mp2t ts;
    video/mp4 mp4;
    video/mpeg mpeg mpg;
    video/quicktime mov;
    video/webm webm;
    video/x-flv flv;
    video/x-m4v m4v;
    video/x-mng mng;
    video/x-ms-asf asx asf;
    video/x-ms-wmv wmv;
    video/x-msvideo avi;
}

# configuration file /etc/nginx/sites-enabled/netbox:
server {
    listen [::]:443 ssl ipv6only=off;

    # CHANGE THIS TO YOUR SERVER'S NAME
    server_name netbox.air-band.net;

    ssl_certificate /etc/ssl/certs/netbox.crt;
    ssl_certificate_key /etc/ssl/private/private.key;

    client_max_body_size 25m;

    location /static/ {
        alias /opt/netbox/netbox/static/;
    }

    location / {
        proxy_pass http://127.0.0.1:8001;
        proxy_set_header X-Forwarded-Host $http_host;
        proxy_set_header X-Real-IP $remote_addr;
        proxy_set_header X-Forwarded-Proto $scheme;
    }
}

server {
    # Redirect HTTP traffic to HTTPS
    listen [::]:80 ipv6only=off;
    server_name _;
    return 301 https://$host$request_uri;
}

```

---

<div class="post-metadata">

### Author: ![MikeMcQ](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/mikemcq/32/52772_2.png) [@MikeMcQ](https://community.letsencrypt.org/u/MikeMcQ)
#### Post date: [October 24, 2023, 2:36pm UTC](https://community.letsencrypt.org/t/certbot-failed-to-authenticate-some-domains/207200/6 "2023-10-24T14:36:50Z")

</div>

I am pretty sure the trouble is from the server\_name in your port 80 server block just being generic. Changing it to match the domain for the cert should work.

If you really want a default block to redirect then create a new server block like below instead. Although, you may need to change your listen statement format because I am pretty sure ipv6only=off can only be done once per nginx per port. Ask if you want help with that.

So, your port 80 server block like this

```plaintext
server {
    # Redirect HTTP traffic to HTTPS
    listen [::]:80 ipv6only=off;
# server_name _;
    server_name netbox.air-band.net;  
    return 301 https://$host$request_uri;
}

```

---

<div class="post-metadata">

### Author: ![airband](https://avatars.discourse-cdn.com/v4/letter/a/90db22/32.png) [@airband](https://community.letsencrypt.org/u/airband)
#### Post date: [October 24, 2023, 2:46pm UTC](https://community.letsencrypt.org/t/certbot-failed-to-authenticate-some-domains/207200/7 "2023-10-24T14:46:38Z")

</div>

Fixed, thank you so much Mike that was bang on the money!!!

Legend!!

---

<div class="post-metadata">

### Author: ![system](https://global.discourse-cdn.com/letsencrypt/original/3X/c/a/ca6c06ea1ea201324bba7048c6841ce60236468d.png) [@system](https://community.letsencrypt.org/u/system)
#### Post date: [November 23, 2023, 2:46pm UTC](https://community.letsencrypt.org/t/certbot-failed-to-authenticate-some-domains/207200/8 "2023-11-23T14:46:51Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
