Certbot - Error getting validation data

Please fill out the fields below so we can help you better.

My domain is: cms.goandlive.com

I ran this command: ./certbot-auto --apache

It produced this output:
Failed authorization procedure. cms.goandlive.com (tls-sni-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: Error getting validation data

My web server is (include version): Apache/2.4.18

The operating system my web server runs on is (include version): Ubuntu 16.04.3 LTS

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

I don’t understand my error. I have a correct A DNS record.
Firewall rules seems to be good.
Thanks for your help.

Are you sure your firewall rules and/or DNS A record are ok? Domain resolves to and if I try to ping this address, I receive “Destination Host Unreachable” from (which is probably a router address).

Ping isn’t necessarily the best tool to verify connectivity - all kinds of things drop ICMP. I was able to curl the page.

However, it appears this has been resolved already:

    Not Before: Aug 30 11:39:00 2017 GMT
    Not After : Nov 28 11:39:00 2017 GMT
Subject: CN=cms.goandlive.com

@nicoags, could you please mark your topic as resolved, as it appears you were able to successfully issue a certificate?

1 Like

It was a routing problem from the service provider.
Access to the website worked from some network but not for all.
It’s solved now, thanks for your help.


@jared.m: at the time I was checking, 80 i 443 were not responding, that’s why I even bothered trying to use ping :wink: Actively returning “Destination Host Unreachable” from router address is somewhat different from dropping ICMP altogether. (But I agree that ping is not necessarily the best tool in the general case.)

@nicoags: glad to hear it works now! :slight_smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.