Certbot certificate issue error To fix these errors, please make sure that your domain name was entered correctly and the DNS A/AAAA record(s) for that domain contain(s) the right IP address

Domain name - afromelo.com

command i ran - sudo certbot certonly --webroot -w /var/www/html -d afromelo.com -d www.afromelo.com

output:
The following errors were reported by the server:

Domain: afromelo.com
Type: unauthorized
Detail: Invalid response from
http://afromelo.com/.well-known/acme-challenge/CURqdGgHTvL4wAkfX-kTfruYfwZoC9AyTv1Kza3dE4c
[18.222.197.16]: "<!doctype html>\r\n<html
lang="en-US">\r\n\r\n\r\n\t<meta
charset="UTF-8">\r\n\t<meta name="viewport"
content="width=device-width, ini"

Domain: www.afromelo.com
Type: unauthorized
Detail: Invalid response from
http://www.afromelo.com/.well-known/acme-challenge/A3aOJ6kPL8eoULw3XJLrFAEpDZmhSEPcxCfbG6Pce5c
[18.222.197.16]: "<!doctype html>\r\n<html
lang="en-US">\r\n\r\n\r\n\t<meta
charset="UTF-8">\r\n\t<meta name="viewport"
content="width=device-width, ini"

To fix these errors, please make sure that your domain name was
entered correctly and the DNS A/AAAA record(s) for that domain
contain(s) the right IP address.

OS & server: I use a Amazon linux

Hi @music93, and welcome to the LE community forum :slight_smile:

Let's begin unraveling this problem with the output of:
sudo apachectl -S

1 Like

Thanks for the swift reply.

here is the output

$ sudo apachectl -S
AH00526: Syntax error on line 100 of /etc/httpd/conf.d/ssl.conf:
SSLCertificateFile: file '/etc/pki/tls/certs/localhost.crt' does not exist or is empty

Please show this file:

[you probably don't even need it - we'll see]

here it is

#   have perfect forward secrecy - if the server's key is
#
# When we also provide SSL we have to listen to the 
# the HTTPS port in addition.
#
Listen 443 https

##
##  SSL Global Context
##
##  All SSL configuration in this context applies both to
##  the main server and all SSL-enabled virtual hosts.
##

#   Pass Phrase Dialog:
#   Configure the pass phrase gathering process.
#   The filtering dialog program (`builtin' is a internal
#   terminal dialog) has to provide the pass phrase on stdout.
SSLPassPhraseDialog exec:/usr/libexec/httpd-ssl-pass-dialog

#   Inter-Process Session Cache:
#   Configure the SSL Session Cache: First the mechanism 
#   to use and second the expiring timeout (in seconds).
SSLSessionCache         shmcb:/run/httpd/sslcache(512000)
SSLSessionCacheTimeout  300

#   Pseudo Random Number Generator (PRNG):
#   Configure one or more sources to seed the PRNG of the 
#   SSL library. The seed data should be of good random quality.
#   WARNING! On some platforms /dev/random blocks if not enough entropy
#   is available. This means you then cannot use the /dev/random device
#   because it would lead to very long connection times (as long as
#   it requires to make more entropy available). But usually those
#   platforms additionally provide a /dev/urandom device which doesn't

#   block. So, if available, use this one instead. Read the mod_ssl User
#   Manual for more details.
SSLRandomSeed startup file:/dev/urandom  256
SSLRandomSeed connect builtin
#SSLRandomSeed startup file:/dev/random  512
#SSLRandomSeed connect file:/dev/random  512
#SSLRandomSeed connect file:/dev/urandom 512

#
# Use "SSLCryptoDevice" to enable any supported hardware
# accelerators. Use "openssl engine -v" to list supported
# engine names.  NOTE: If you enable an accelerator and the
# server does not start, consult the error logs and ensure
# your accelerator is functioning properly. 
#
SSLCryptoDevice builtin
#SSLCryptoDevice ubsec

##
## SSL Virtual Host Context
##

<VirtualHost _default_:443>

# General setup for the virtual host, inherited from global configuration
#DocumentRoot "/var/www/html"
#ServerName www.example.com:443

# Use separate log files for the SSL virtual host; note that LogLevel
# is not inherited from httpd.conf.
ErrorLog logs/ssl_error_log
TransferLog logs/ssl_access_log
                                 
LogLevel warn

#   SSL Engine Switch:
#   Enable/Disable SSL for this virtual host.
SSLEngine on

#   SSL Protocol support:
# List the enable protocol levels with which clients will be able to
# connect.  Disable SSLv2 access by default:
SSLProtocol all -SSLv3

#   SSL Cipher Suite:
#   List the ciphers that the client is permitted to negotiate.
#   See the mod_ssl documentation for a complete list.
SSLCipherSuite HIGH:MEDIUM:!aNULL:!MD5:!SEED:!IDEA

#   Speed-optimized SSL Cipher configuration:
#   If speed is your main concern (on busy HTTPS servers e.g.),
#   you might want to force clients to specific, performance
#   optimized ciphers. In this case, prepend those ciphers
#   to the SSLCipherSuite list, and enable SSLHonorCipherOrder.
#   Caveat: by giving precedence to RC4-SHA and AES128-SHA
#   (as in the example below), most connections will no longer
#   have perfect forward secrecy - if the server's key is
#   compromised, captures of past or future traffic must be
#   considered compromised, too.
#SSLCipherSuite RC4-SHA:AES128-SHA:HIGH:MEDIUM:!aNULL:!MD5
#SSLHonorCipherOrder on 

#   Server Certificate:
# Point SSLCertificateFile at a PEM encoded certificate.  If

# the certificate is encrypted, then you will be prompted for a
# pass phrase.  Note that a kill -HUP will prompt again.  A new
# certificate can be generated using the genkey(1) command.
SSLCertificateFile /etc/pki/tls/certs/localhost.crt

#   Server Private Key:
#   If the key is not combined with the certificate, use this
#   directive to point at the key file.  Keep in mind that if
#   you've both a RSA and a DSA private key you can configure
#   both in parallel (to also allow the use of DSA ciphers, etc.)
SSLCertificateKeyFile /etc/pki/tls/private/localhost.key

#   Server Certificate Chain:
#   Point SSLCertificateChainFile at a file containing the
#   concatenation of PEM encoded CA certificates which form the
#   certificate chain for the server certificate. Alternatively
#   the referenced file can be the same as SSLCertificateFile
#   when the CA certificates are directly appended to the server
#   certificate for convinience.
#SSLCertificateChainFile /etc/pki/tls/certs/server-chain.crt

#   Certificate Authority (CA):
#   Set the CA certificate verification path where to find CA
#   certificates for client authentication or alternatively one
#   huge file containing all of them (file must be PEM encoded)
#SSLCACertificateFile /etc/pki/tls/certs/ca-bundle.crt

#   Client Authentication (Type):
                    
#   Client certificate verification type and depth.  Types are
#   none, optional, require and optional_no_ca.  Depth is a
#   number which specifies how deeply to verify the certificate
#   issuer chain before deciding the certificate is not valid.
#SSLVerifyClient require
#SSLVerifyDepth  10

#   Access Control:
#   With SSLRequire you can do per-directory access control based
#   on arbitrary complex boolean expressions containing server
#   variable checks and other lookup directives.  The syntax is a
#   mixture between C and Perl.  See the mod_ssl documentation
#   for more details.
#<Location />
#SSLRequire (    %{SSL_CIPHER} !~ m/^(EXP|NULL)/ \
#            and %{SSL_CLIENT_S_DN_O} eq "Snake Oil, Ltd." \
#            and %{SSL_CLIENT_S_DN_OU} in {"Staff", "CA", "Dev"} \
#            and %{TIME_WDAY} >= 1 and %{TIME_WDAY} <= 5 \
#            and %{TIME_HOUR} >= 8 and %{TIME_HOUR} <= 20       ) \
#           or %{REMOTE_ADDR} =~ m/^192\.76\.162\.[0-9]+$/
#</Location>

#   SSL Engine Options:
#   Set various options for the SSL engine.
#   o FakeBasicAuth:
#     Translate the client X.509 into a Basic Authorisation.  This means that
#     the standard Auth/DBMAuth methods can be used for access control.  The
#     user name is the `one line' version of the client's X.509 certificate.
#     Note that no password is obtained from the user. Every entry in the user
#     file needs this password: `xxj31ZMTZzkVA'.
#   o ExportCertData:


#     This exports two additional environment variables: SSL_CLIENT_CERT and
#     SSL_SERVER_CERT. These contain the PEM-encoded certificates of the
#     server (always existing) and the client (only existing when client
#     authentication is used). This can be used to import the certificates
#     into CGI scripts.
#   o StdEnvVars:
#     This exports the standard SSL/TLS related `SSL_*' environment variables.
#     Per default this exportation is switched off for performance reasons,
#     because the extraction step is an expensive operation and is usually
#     useless for serving static content. So one usually enables the
#     exportation for CGI and SSI requests only.
#   o StrictRequire:
#     This denies access when "SSLRequireSSL" or "SSLRequire" applied even
#     under a "Satisfy any" situation, i.e. when it applies access is denied
#     and no other module can change it.
#   o OptRenegotiate:
#     This enables optimized SSL connection renegotiation handling when SSL
#     directives are used in per-directory context. 
#SSLOptions +FakeBasicAuth +ExportCertData +StrictRequire
<Files ~ "\.(cgi|shtml|phtml|php3?)$">
    SSLOptions +StdEnvVars
</Files>
<Directory "/var/www/cgi-bin">
    SSLOptions +StdEnvVars
</Directory>

#   SSL Protocol Adjustments:
#   The safe and default but still SSL/TLS standard compliant shutdown
#   approach is that mod_ssl sends the close notify alert but doesn't wait for
#   the close notify alert from client. When you need a different shutdown
#   approach you can use one of the following variables:
#   o ssl-unclean-shutdown:
                              
#     This forces an accurate shutdown when the connection is closed, i.e. a
#     SSL close notify alert is send and mod_ssl waits for the close notify
#     alert of the client. This is 100% SSL/TLS standard compliant, but in
#     practice often causes hanging connections with brain-dead browsers. Use
#     this only for browsers where you know that their SSL implementation
#     works correctly. 
#   Notice: Most problems of broken clients are also related to the HTTP
#   keep-alive facility, so you usually additionally want to disable
#   keep-alive for those clients, too. Use variable "nokeepalive" for this.
#   Similarly, one has to force some clients to use HTTP/1.0 to workaround
#   their broken HTTP/1.1 implementation. Use variables "downgrade-1.0" and
#   "force-response-1.0" for this.
BrowserMatch "MSIE [2-5]" \
         nokeepalive ssl-unclean-shutdown \
         downgrade-1.0 force-response-1.0

#   Per-Server Logging:
#   The home of a custom SSL log file. Use this when you want a
#   compact non-error SSL logfile on a virtual host basis.
CustomLog logs/ssl_request_log \
          "%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"

</VirtualHost>

There are two "parts" to that file:
[abbreveated for clarity]

Part #1

Listen 443 https
SSLPassPhraseDialog exec:/usr/libexec/httpd-ssl-pass-dialog
SSLSessionCache         shmcb:/run/httpd/sslcache(512000)
SSLSessionCacheTimeout  300
SSLRandomSeed startup file:/dev/urandom  256
SSLRandomSeed connect builtin
SSLCryptoDevice builtin

Part #2:

<VirtualHost _default_:443>
  ErrorLog logs/ssl_error_log
  TransferLog logs/ssl_access_log
  LogLevel warn
  SSLEngine on
  SSLProtocol all -SSLv3
  SSLCipherSuite HIGH:MEDIUM:!aNULL:!MD5:!SEED:!IDEA
  SSLCertificateFile /etc/pki/tls/certs/localhost.crt
  SSLCertificateKeyFile /etc/pki/tls/private/localhost.key
  <Files ~ "\.(cgi|shtml|phtml|php3?)$">
    SSLOptions +StdEnvVars
  </Files>
  <Directory "/var/www/cgi-bin">
    SSLOptions +StdEnvVars
  </Directory>
  BrowserMatch "MSIE [2-5]" \
         nokeepalive ssl-unclean-shutdown \
         downgrade-1.0 force-response-1.0
  CustomLog logs/ssl_request_log \
          "%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"
</VirtualHost>

The first part is probably "useful" and likely required.
The second part (the Virtual Host) is not useful and should be removed.

So i deleted the second part,and it seem i eliminated the syntax error.

but i got this error after it prompt me to enter my domain names. Please what do i do here

here is the error i got.

Requesting a certificate for afromelo.com and www.afromelo.com
Performing the following challenges:
http-01 challenge for afromelo.com
http-01 challenge for www.afromelo.com
Cleaning up challenges
Unable to find a virtual host listening on port 80 which is currently needed for Certbot to prove to the CA that you control your domain. Please add a virtual host for port 80.

That means that you should have a fully functional HTTP site before trying to secure it.
So, you will need to create a vhost config that covers both of those names.
[Then restart the web service]

1 Like

Sure, i followed a guide on how to set up a vhost config file, and i was able to get here. Please point out if there is any adjustment i need to make. Below is my content and the error i got.

<br />
<VirtualHost *:80></p>
<p># REQUIRED. Set this to the host/domain/subdomain that<br />
<p>ServerName afromelo.com.</p>
<p># Optional. You can specify additional host names that<br />
<p>#ServerAdmin afromelo866@gmail.com</p>
<p># Optional. Uncomment this if you want to specify<br />
<p>#ServerAdmin afromelo866@gmail.com</p>
<p># Optional. Uncomment this if you want to specify<br />
<p>#ErrorLog /var/www/vhosts/logs/error_log</p>
<p># REQUIRED. Let's make sure that .htaccess files work on<br />
<p><Directory /var/www/vhosts/afromelo.com><br />
AllowOverride All<br />
</Directory></p>
<p></VirtualHost><br />

here is the error i got,when i restart apache

httpd: Syntax error on line 362 of /etc/httpd/conf/httpd.conf: Syntax error on line 28 of /etc/httpd/conf.d/vhost.conf: Expected

but saw

Where did i go wrong

Yes i followed a guide,and i am in the process of completeing the vhost config setup. But i encountered an issue when i restarted apache.

here is the error i got

httpd: Syntax error on line 362 of /etc/httpd/conf/httpd.conf: Syntax error on line 28 of /etc/httpd/conf.d/vhost.conf: Expected </p><Directory> but saw </Directory></p>
Here are the content of vhosts.conf


<br />
<VirtualHost *:80></p>
<p># REQUIRED. Set this to the host/domain/subdomain that<br />
<p>ServerName afromelo.com.</p>
<p># Optional. You can specify additional host names that<br />
<p>#ServerAdmin afromelo866@gmail.com</p>
<p># Optional. Uncomment this if you want to specify<br />
<p>#ServerAdmin afromelo866@gmail.com</p>
<p># Optional. Uncomment this if you want to specify<br />
<p>#ErrorLog /var/www/vhosts/logs/error_log</p>
<p># REQUIRED. Let's make sure that .htaccess files work on<br />
<p><Directory /var/www/vhosts/afromelo.com><br />
AllowOverride All<br />
</Directory></p>
<p></VirtualHost><br />

Please where did i go wrong

The entire file seems to have been modified to HTML code.
There is no <br /> nor <p> (</p>) used anywhere in Apache configs.
Please remove them all and try again.

I removed the <br/> nor <p> and the rest and replaced all that content in /etc/httpd/conf.d/vhost.conf with

<VirtualHost *:80>
    ServerAdmin afromelo866@gmail.com
    ServerName afromelo.com
    ServerAlias www.afromelo.com
    DocumentRoot /var/www/html
</VirtualHost>

i got this error again

Detail: Invalid response from
http://www.afromelo.com/.well-known/acme-challenge/A3aOJ6kPL8eoULw3XJLrFAEpDZmhSEPcxCfbG6Pce5c
[18.222.197.16]: "<!doctype html>\r\n<html
lang="en-US">\r\n\r\n\r\n\t<meta
charset="UTF-8">\r\n\t<meta name="viewport"
content="width=device-width, ini"

To fix these errors, please make sure that your domain name was
entered correctly and the DNS A/AAAA record(s) for that domain
contain(s) the right IP address.

could it be i didn't input the right codes in /etc/httpd/conf.d/vhost.conf
pdo assist me with the right codes if you can i am running out of certificates limit

Let's begin to unravel the problem with the output of these:
[since changes have been made]
curl -4 ifconfig.co
sudo apachectl -S

1 Like

Here is the output for sudo apachectl -S

VirtualHost configuration:
ServerRoot: "/etc/httpd"
Main DocumentRoot: "/var/www/html"
Main ErrorLog: "/etc/httpd/logs/error_log"
Mutex proxy-balancer-shm: using_defaults
Mutex rewrite-map: using_defaults
Mutex authdigest-client: using_defaults
Mutex lua-ivm-shm: using_defaults
Mutex proxy: using_defaults
Mutex authn-socache: using_defaults
Mutex default: dir="/run/httpd/" mechanism=default
Mutex mpm-accept: using_defaults
Mutex cache-socache: using_defaults
Mutex authdigest-opaque: using_defaults
Mutex watchdog-callback: using_defaults
PidFile: "/run/httpd/httpd.pid"
Define: DUMP_VHOSTS
Define: DUMP_RUN_CFG
User: name="apache" id=48
Group: name="apache" id=48

output when i input command curl -4 ifconfig.co

3.14.28.177

Maybe I was unclear.
You need to run those commands on the system that is trying to obtain a cert.
Based on the name: afromelo.com
I would expect the IP shown by the curl command to match it; but it doesn't:

Name:    afromelo.com
Address: 18.222.197.16

Please run those commands on the server.

My bad, i made a mistake.

here is the output for sudo apachectl -S

VirtualHost configuration:
*:80 afromelo.com (/etc/httpd/conf/httpd.conf:43)
ServerRoot: "/etc/httpd"
Main DocumentRoot: "/var/www/html"
Main ErrorLog: "/etc/httpd/logs/error_log"
Mutex lua-ivm-shm: using_defaults
Mutex ssl-stapling: using_defaults
Mutex proxy: using_defaults
Mutex authn-socache: using_defaults
Mutex ssl-cache: using_defaults
Mutex default: dir="/run/httpd/" mechanism=default
Mutex mpm-accept: using_defaults
Mutex cache-socache: using_defaults
Mutex authdigest-opaque: using_defaults
Mutex watchdog-callback: using_defaults
Mutex proxy-balancer-shm: using_defaults
Mutex rewrite-map: using_defaults
Mutex ssl-stapling-refresh: using_defaults
Mutex authdigest-client: using_defaults
PidFile: "/run/httpd/httpd.pid"
Define: DUMP_VHOSTS
Define: DUMP_RUN_CFG
User: name="apache" id=48
Group: name="apache" id=48

And output for curl -4 ifconfig.co
18.216.203.198

That is wierd that IP is slightly different.
how do i fix it right

  1. Speak with your HSP about why it changed and if it will it change again.
  2. Update the A record in the DNS zone to this new number.

It changed,it just changed again to this 3.136.158.188 (the IP changed again)

and here is the output i got

IMPORTANT NOTES:

Please stop requesting any more certs until the IP issue is resolved.
The DNS entry for the FQDN must match the current IP, in order for LE to reach your server and validate the HTTP authentication request.
But even if you switch authentication requests, or even completely process the certificate manually and manage to obtain a cert, how is anyone ever going to reach your site if the IP keeps changing?

Are you sure you have a hosting plan?
How do you even reach the server?

I use AWS Free tier. and currently setting up certbot using AWS CLI.