Certbot can't find default configuration cli.ini running a docker container with rkt under ContainerOS

Hello.
I have a pc at home that has CoreOS Installed with the following server info:

NAME="Container Linux by CoreOS"
ID=coreos
VERSION=1451.2.0
VERSION_ID=1451.2.0
BUILD_ID=2017-06-22-2207
PRETTY_NAME="Container Linux by CoreOS 1451.2.0 (Ladybug)"
ANSI_COLOR="38;5;75"
HOME_URL="https://coreos.com/"
BUG_REPORT_URL="https://issues.coreos.com"
COREOS_BOARD="amd64-usr"

I run CertBot container with the following command:

rkt run --net=host --volume letsencrypt-logs,kind=host,source=/mnt/storage/certbot/logs,readOnly=false --volume volume-var-lib-letsencrypt,kind=host,source=/mnt/storage/certbot/lib,readOnly=false --volume volume-etc-letsencrypt,kind=host,source=/mnt/storage/certbot/config,readOnly=false --volume nginx-webroot,kind=host,source=/mnt/storage/nginx/html  --mount volume=nginx-webroot,target=/var/www/letsencrypt --mount volume=letsencrypt-logs,target=/var/log/letsencrypt --mount volume=volume-etc-letsencrypt,target=/etc/letsencrypt --mount volume=volume-var-lib-letsencrypt,target=/var/lib/letsencrypt --insecure-options=image docker://certbot/certbot 

I get the following output:

[95375.641164] certbot[5]: Certbot doesn’t know how to automatically configure the web server on this system. However, it can still get a certificate for you. Please run “certbot certonly” to do so. You’ll need to manually configure your web server to use the resulting certificate.

I mounted volume-etc-letsencrypt that contains cli.ini that has my domain configuration. so it probably didn’t look there.

what am I missing? why it can’t find the default configuration file at /etc/letsencrypt/cli.ini ?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.