Certbot: Cannot create user data directory

i have cerbot installed and running for a few years now without issues.
first, thanks to all who make this possible.

according to the logs the following version was installed:
certbot version: 1.32.2

but since begin of 2023 certbot renew stopped working
the error is:
cannot create user data directory: /snap/certbot/2772: Not a directory

I first tried to update snap and certbot with "snap refresh"
update of snap was successful but update of certbot displayed same error.

i removed certbot from snap, uninstalled snap and reinstalled it.
then i tried to reinstall certbot, but keep getting this error.

any ideas ?

-- Ron

1 Like

maybe same problem?


Can you backup your data and reimage that system [or move to another VM (if virtual)]?
[i.e. Start over - LOL]


@orangepizza this seems to be the same problem, but, there is no solution provided.
@rg305 this is a productive system on centos7. i have no way to move it. i switched to debian 11 and reinstalled all from scratch. now certbot is running as expected.

but the question remains: why does it happen ? how to solve it ? how to avoid such issues in future, in case of snap upgrade ? is snap a good solution for certbot ?

Do you have multiple versions of certbot installed?

It is the recommended method.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.