Certbot and DNS Made Easy plugin

I am going to try asking for help again.

I have spent yet another day trying numerous different ways to try and get the DNS Made Easy plugin installed and working for Certbot.

Snap Docker, etc.

I have a few main servers, and some backup servers. This was supposed to be easy, using the DNS Made Easy plugin for the verification of the backup servers, because the main servers are the ones that are live for the domains.

I tried installing the plugin via Snap today:
sudo snap install certbot-dns-dnsmadeeasy

Snap says it is installed:
snap "certbot-dns-dnsmadeeasy" is already installed, see 'snap help refresh'
...but Certbot does not list it:
certbot plugins


  • apache
    Description: Apache Web Server plugin
    Interfaces: IAuthenticator, IInstaller, IPlugin
    Entry point: apache = certbot_apache.entrypoint:ENTRYPOINT

  • standalone
    Description: Spin up a temporary webserver
    Interfaces: IAuthenticator, IPlugin
    Entry point: standalone = certbot.plugins.standalone:Authenticator

  • webroot
    Description: Place files in webroot directory
    Interfaces: IAuthenticator, IPlugin
    Entry point: webroot = certbot.plugins.webroot:Authenticator


Someone else suggested acme.sh which worked as far as issuing the certificates, but it does not seem to be installing them in Apache. It does not even act like it is trying, and is not working after restarting apache, or rebooting the server.

The Certbot with DNS Made Easy plugin should work fine for what I need, but I can never seem to get Certbot and the Plugin to ever work.

Anyone have any other suggestions?
It would be nice if I could actually get this working, after well over a year of trying 100's of different ways to install Certbot and the DNS Made Easy Plugin for Ubuntu 18.04 with Apache.

Thanks for any help!

1 Like

Install the acme.sh provided cert into Apache manually.

What is not working? Apache?
If so, start fixing that with:
apachectl -S
[most of the times the problem is made obvious with that check]
Or restore a backup of it.

1 Like

If you'd like to try to get Certbot working, I'd recommend:

  1. Temporarily uninstalling the Certbot snap(s) by running a command like sudo snap remove certbot certbot-dns-dnsmadeeasy
  2. Following the instructions at https://certbot.eff.org/lets-encrypt/ubuntubionic-apache#wildcard.

In your particular case, I suspect your problem is certbot in your PATH doesn't refer to the Certbot snap and instead refers to something like Certbot installed through apt.

2 Likes

Try looking at the top of your letsencrypt.log (most often found in /var/log/letsencrypt/): with recent versions of certbot (i.e.: if certbot is being ran through snap) it will tell you from which path certbot was actually loaded (look for the line "Location of certbot entry point: ...")! This could differentiate between certbots installed through snap or apt. Note: a version from apt is probably too old to have this new log line.

2 Likes

OR
You could just remove the apt version (if it exists)
And ensure you only run the snap version of certbot.

1 Like