Certbot 3rd Party Plugin for Gandi - Counldn't find any match with "SHS-NAME"


#1

Please fill out the fields below so we can help you better.

My domain is: www.lespavesgourmands-thueyts.fr

I ran this command:

certbot run --domains VHOST
–authenticator letsencrypt-gandi:gandi-shs
–letsencrypt-gandi:gandi-shs-name Les Pavés Gourmands
–letsencrypt-gandi:gandi-shs-vhost VHOST
–letsencrypt-gandi:gandi-shs-api-key API-KEY
–installer letsencrypt-gandi:gandi-shs

It produced this output:

Cleaning up challenges
Encountered exception during recovery
Couldn’t find any match for Les Pavés Gourmands
Traceback (most recent call last):
File “/usr/lib/python2.7/dist-packages/certbot/error_handler.py”, line
99, in _call_registered
self.funcs-1
File “/usr/lib/python2.7/dist-packages/certbot/auth_handler.py”, line
280, in _cleanup_challenges
self.auth.cleanup(achalls)
File “/home/deb-ssh/letsencrypt-gandi/letsencrypt_gandi/shs.py”, line
377, in cleanup
user, sftp_url = self._lookup_shs()
File “/home/deb-ssh/letsencrypt-gandi/letsencrypt_gandi/shs.py”, line
189, in _lookup_shs
paas = self.shs_info
File “/home/deb-ssh/letsencrypt-gandi/letsencrypt_gandi/shs.py”, line
98, in shs_info
"Couldn’t find any match for {0}".format(self.shs_name))
PluginError: Couldn’t find any match for Les Pavés Gourmands
Couldn’t find any match for Les Pavés Gourmands

My operating system is (include version): Debian Jessie 8.8

My web server is (include version): Gandi Simple Hosting - Size M - Appache

My hosting provider, if applicable, is: Gandi

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): Wordpress

The SHS name of my simple Hosting is “Les Pavés Gourmands” and I think the space in the name give me an error with my certbot run command ???

Am I right ?

Regards

T


#2

Hi @it-tips,

I have never seen --letsencrypt-gandi before and I guess we’ll have to learn more about it. :slight_smile:

I don’t even know what an SHS name is, but I have two guesses to think about:

① Like you suggested, the spaces might be a problem. You could try putting the whole SHS name in quotes, like --letsencrypt-gandi:gandi-shs-name "Les Pavés Gourmands"

② The é character might be confusing some of the software because of character set representation problems, because it is a non-ASCII character. You could try to configure that --letsencrypt-gandi is OK with non-ASCII characters and that they are also allowed in an SHS name (and that some other representation of the é character isn’t meant to be used in this context).

③ The second issue might be a bug with --letsencrypt-gandi if non-ASCII characters are rare in SHS names. In that case it would need to be reported to the Gandi developers. This seems less likely since Gandi is also a French company, so I would expect that they would have thought about this issue already.


#3

Hi @it-tips

This is a third party plugin for certbot so while people may be able to assist the shortest route to success is usually to talk to the plugin author.

Having a look at the syntax you posted vs instructions it looks like you haven’t called the plugin properly

There is a good step by step guide here: http://wiki.gandi.net/tutorials/letsencrypt

Andrei


#4

Hi guys,

Firstly thanks to both of you for your replies, I asked gandi but with no answer all day long I came here to find some help and I foun it !

Thanks schoen, the probleme was definitly : “Les Pavés Gourmands”

After that “” added the command ran and my website is now https !!

Solved !


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.