Cert not working on Ubuntu 22.04

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: floridamyst.com

I ran this command: udo snap install core; sudo snap refresh core

sudo snap install --classic certbot

sudo ln -s /snap/bin/certbot /usr/bin/certbot

sudo certbot --apache

It produced this output: Successfully received certificate.
Certificate is saved at: /etc/letsencrypt/live/floridamyst.com/fullchain.pem
Key is saved at: /etc/letsencrypt/live/floridamyst.com/privkey.pem
This certificate expires on 2023-12-16.
These files will be updated when the certificate renews.
Certbot has set up a scheduled task to automatically renew this certificate in the background.

Deploying certificate
Some rewrite rules copied from /etc/apache2/sites-enabled/floridamyst.com.conf were disabled in the vhost for your HTTPS site located at /etc/apache2/sites-available/floridamyst.com-le-ssl.conf because they have the potential to create redirection loops.
Successfully deployed certificate for floridamyst.com to /etc/apache2/sites-available/floridamyst.com-le-ssl.conf
Added an HTTP->HTTPS rewrite in addition to other RewriteRules; you may wish to check for overall consistency.
Congratulations! You have successfully enabled HTTPS on https://floridamyst.com

My web server is (include version): apache2

The operating system my web server runs on is (include version): ubuntu 22.04

My hosting provider, if applicable, is: linode

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): 2.6.0

Your certificate is valid for floridamyst.com but not for www.floridamyst.com

If you want it to be valid for www.floridamyst.com too, you should add a

ServerAlias www.floridamyst.com

line just below

ServerName floridamyst.com

, and rerun certbot.

6 Likes

:slight_smile: :grinning: That was it. Thank you!

4 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.