Cert not issued for Singapore Domain

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: planettel.com.sg

I ran this command:certbot-auto

It produced this output: Does not detect the domain to issue cert

My web server is (include version):apache

The operating system my web server runs on is (include version):Debian

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):1.2.0

I am able to get certs for top level domains. Does letsencrypt support domain name like .com.sg ?

1 Like

Are you getting an error message from Let’s Encrypt?

Certbot detects hostnames based on your Apache ServerName and ServerAlias settings (or the equivalent for Nginx). Do you have a virtual host configured for this domain? Or you can also get certificates for names that Certbot did not automatically detect.

1 Like

I have configured several top level domains using virtual hosts and when I run certbot-auto it will automatically detect all the domains with virtual hosts so I can select the domain to get letsencrypt cert. However, for this domain when I run certbot-auto it does not list it in the domains to get cert. Strange! I do have the virtual host configured for this domain ‘planettel.com.sg’

Following is my entry in the virtual host conf file in ‘sites-available’:

<VirtualHost *:80>

ServerName planettel.com.sg
ServerAlias www.planettel.com.sg
DocumentRoot /var/www/planettel.com.sg/public_html
ErrorLog /var/www/planettel.com.sg/error.log
CustomLog /var/www/planettel.com.sg/requests.log combined

RewriteEngine on
RewriteCond %{SERVER_NAME} =planettel.com.sg

comment out the following if no https needed.

RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]

1 Like

Is the virtual host enabled?

1 Like

I have tried commenting out the ‘RewriteRule’ line. No difference.
Yes. the site is enabled in the ‘sites-enabled’ directory

1 Like

Changing the subject a bit, did you know that http://planettel.com.sg/ redirects to https://edengardenhub.com/, and http://www.planettel.com.sg/ redirects to http://planettel.com.sg/? Apache isn’t running the configuration you showed.

But if the configuration exists but the issue is that Apache has not yet been reloaded, that would not be a problem.

Can you maybe post Certbot’s complete output, and the output of “sudo apachectl -t -D DUMP_VHOSTS”?

1 Like

Hi, Thanks for the prompt responses and helping me to debug.
I realised that i made a typo error while enabling the virtual host.
I corrected that error and the problem has been resolved.
This issue may be closed.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.