Cert installed byDNSAPI good ,But program does not auto write any token in account.conf

Installed by the DNSAPI method work well.
But it does not write token and other data to "account.conf".

I retrieved the community's issure history.

Similar to my question. But I have a fresh install. My configuration file itself is clean

curl https://get.acme.sh | sh
source ~/.bashrc
acme.sh --upgrade

export CF_Token="123123"
export CF_Account_ID="123123"

~/.acme.sh/acme.sh --issue --dns dns_cf -d domain.abc -d *.domain.abc --server letsencrypt --test
~/.acme.sh/acme.sh --issue --dns dns_cf -d domain.abc -d *.domain.abc --force --server letsencrypt

cert installed indeed.but I check the account.conf.

cat ~/acme.sh/account.conf


Should I write constants manually?
But I didn't find any configuration instructions for account.conf.
Where should I look for the correct constant names?

I tried to reinstall. But the result did not change.
btw although I used the --test command. But I still get Duplicate Certificate Limit.

Hello @totzsj, welcome to the Let's Encrypt community. :slightly_smiling_face:

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

Thank you for assisting us in helping YOU!

1 Like

Are you using one of the DNS providers on this list DNS providers who easily integrate with Let's Encrypt DNS validation?

1 Like

I think you might find better/more specific help with this directly through their support:
GitHub - acmesh-official/acme.sh: A pure Unix shell script implementing ACME client protocol


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.