Cerbot renewal successful but no DNS record found

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:captlife.com

I managed to renew my SSL certificate and it showed sucessful renewal with an updated expirary date. However, when going to my site, I was met with a DNS_PROBE_FINISHED_NXDOMAIN error. Using mxtoolbox lookup, it also said no DNS record found. Is there any way i can remedy this?
My web server is (include version):

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): yes Amazon lightsail

I'm not sure what information to provide that would help

is this a common problem?

Hello @j0ey07, welcome to the Let's Encrypt community. :slightly_smiling_face:

Here is a list of issued certificates crt.sh | captlife.com.

Here DNS Spy report for captlife.com I do not see any DNS A, AAAA, or CNAME Record; which is fine if you are not expecting to be accessed from the Internet and means you can only use the ACME DNS-01 Challenge to obtain a Let's Encrypt Certificate.

Also different DNS tool captlife.com | DNSViz show the same basic result.

2 Likes

Sure! Just go to your domain zone editor in the webinterface of your DNS provider and fix it. But that's quite out of the scope of this Community, as we're here for fixing Let's Encrypt/certificate things or directly related to that, but this is a generic DNS issue. Nothing more, nothing less.

4 Likes

No.
When was the last time you used the site?

3 Likes

Hi! Thank you so much for this, unfortunately, whenever i run certbot and try to obtain a Let's encrypt certificate again, it tells me the certificate already exists. I had been using TXT records to get a Let's Encrypt wildcard certificate. Through this process i usually have the DNS record problem resolved, however, despite getting the certificate renewed, the DNS problem is still there. Im quite new to this so idk if this was a fault on my end and im not sure how to use any other method other than this tutorial Tutorial: Using Let’s Encrypt SSL certificates with your WordPress instance in Amazon Lightsail | Lightsail Documentation.

In short my understanding is that i can only get TXT records when i run certbot for a new certificate but now certbot doesnt allow me to get TXT records because it says the certificate is already renewed. I would love some clarity on this if possible but once again thank you so much! reallyappreciate the help thus far

3 Likes

I see! thank you so much. So sorry im truly quite new to the space but what do you mean by going to the DNS provider and fixing it? I understand this may be out of scope for the community but if any guidance can be given, i would deeply appreciate it. Once again, thank you so much!

2 Likes

oh no. I last used the site a few days ago and updated the certificate using certbot yesterday

1 Like

What name did you use?
What was the URL?

3 Likes

And I could print my certificate and key and then put them into my desk drawer.
Neither of which ensures anyone on the Internet can ever reach, nor use, it.

You obtained a certificate via DNS-01 authentication.
That can be done from any IP address on the Internet.
That does not imply that the site was working.
It only means that your DNS zone and ACME client were working.

There is no IP for the domain: captlife.com
As such it can't be reached by anyone on the Internet.

3 Likes

how do i go about remedying this?

i used it at its usual URL at captlife.com

If this is your domain:
image
Then go to your AWS DNS control page and update the zone.
It needs the IP address of the server hosting the site.

3 Likes

the name serves in this picture are different from the ones stated on my console. it this significant? everything else matches though

Thank you to everyone!! I am very grateful for all the support. esp rg305, your advice has been very helpful and i figured out my issue. I had accidentally deleted my AAAA record while typing in my txt records

5 Likes

never mind the issue has resurfaced

its okay ! i think i finally fixed it haha thank you everyone

4 Likes