Cerbot-auto goes to bootsraping dependencies

My domain is: http://ambossaustralia.com.au

I ran this command: /root/certbot-auto -d ambossaustralia.com.au -d www.ambossaustralia.com.au

It produced this output:

Bootstrapping dependencies for Debian-based OSes… (you can skip this with --no-bootstrap)

Ign:1 http://mirrors.linode.com/debian jessie InRelease

Hit:3 http://mirrors.linode.com/debian jessie Release

and start fetching things and ask After this operation, 986 kB disk space will be freed.

Do you want to continue? [Y/n] …

My web server is (include version): Apache

The operating system my web server runs on is (include version): Debian 8

My hosting provider, if applicable, is: Linode

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): Cannot run certbot-auto --version. Every certbot-auto command will go to the same error that I show you above.

I need help on how to renew my certificate or fix this. Not sure what this error means.

What’s wrong?

Can you pastebin certbot-auto’s full output?

root@flametree:~# /root/certbot-auto -d ambossaustralia.com.au -d www.ambossaustralia.com.au
Bootstrapping dependencies for Debian-based OSes… (you can skip this with --no-bootstrap)
Ign:1 http://mirrors.linode.com/debian jessie InRelease
Hit:3 http://mirrors.linode.com/debian jessie Release
Get:2 http://mirrors.linode.com/debian jessie-updates InRelease [7,340 B]
Hit:4 http://security.debian.org jessie/updates InRelease
Hit:5 https://deb.nodesource.com/node_6.x jessie InRelease
Hit:7 http://apt-longview.linode.com stretch InRelease
Hit:8 http://repo.mysql.com/apt/debian stretch InRelease
Err:8 http://repo.mysql.com/apt/debian stretch InRelease
The following signatures were invalid: EXPKEYSIG 8C718D3B5072E1F5 MySQL Release Engineering mysql-build@oss.oracle.com
Fetched 7,340 B in 0s (8,951 B/s)
Reading package lists… Done
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://repo.mysql.com/apt/debian stretch InRelease: The following signatures were invalid: EXPKEYSIG 8C718D3B5072E1F5 MySQL Release Engineering mysql-build@oss.oracle.com
E: Failed to fetch http://mirrors.linode.com/debian/dists/jessie-updates/InRelease Unable to find expected entry ‘main/source/Sources’ in Release file (Wrong sources.list entry or malformed file)
W: Failed to fetch http://repo.mysql.com/apt/debian/dists/stretch/InRelease The following signatures were invalid: EXPKEYSIG 8C718D3B5072E1F5 MySQL Release Engineering mysql-build@oss.oracle.com
W: Some index files failed to download. They have been ignored, or old ones used instead.
apt-get update hit problems but continuing anyway…
Reading package lists… Done
Building dependency tree
Reading state information… Done
python-dev is already the newest version (2.7.13-2).
gcc is already the newest version (4:6.3.0-4).
python-virtualenv is already the newest version (15.1.0+ds-1).
virtualenv is already the newest version (15.1.0+ds-1).
python is already the newest version (2.7.13-2).
The following additional packages will be installed:
libffi6 libssl1.0.0
Suggested packages:
augeas-doc augeas-tools
The following packages will be upgraded:
libssl1.0.0
The following packages will be DOWNGRADED:
augeas-lenses ca-certificates libaugeas0 libffi-dev libffi6 libssl-dev
openssl
1 upgraded, 0 newly installed, 7 downgraded, 0 to remove and 242 not upgraded.
Need to get 3,952 kB of archives.
After this operation, 986 kB disk space will be freed.
Do you want to continue? [Y/n]

certbot-auto is just running “apt-get update”. Certbot didn’t cause those errors.

Debian Jessie is old. It transitioned to Long Term Support almost a year ago. The jessie-updates repository was recently deleted from the mirrors. The last jessie-updates packages were merged into the jessie repository, so you can stop the error by commenting out jessie-updates in /etc/apt/sources.list.

(Don’t disable the security repository, though!)

You should upgrade to Stretch soon.

I dunno about that.

You should research these issues, post on a Debian website, and/or ask MySQL support.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.