Can't renew on Apache Jessie


#1

Hi friends!
I can’t now get renew, and got error. certbot -v shows me certbot version: 0.10.2 and I think that is the problem. But I can’t find any information, how can I update certbot. Coul you help me or give me a link how can I update. Or maybie is it some other error? Thank you in advance.

My domain is: tour-faq.ru

I ran this command: certbot renew --dry-run

It produced this output: Client with the currently selected authenticator does not support any combination of challenges that will satisfy the CA.
Attempting to renew cert from /etc/letsencrypt/renewal/tour-faq.ru.conf produced an unexpected error: Client with the currently selected authenticator does not support any combination of challenges that will satisfy the CA… Skipping.

My web server is (include version): Apache 2.4.29

The operating system my web server runs on is (include version): Debian Jessie

I can login to a root shell on my machine (yes or no, or I don’t know): yes


#2

Hi,

Welcome.

If you are trying to get certbot updated. Simply run sudo apt-get update

This error message means you are using an depreciated validation method. Please update the certbot or using certonly option to verify using other methods.

Thank you


#3

Unfortunately I don’t think Debian Jessie has any newer version available through apt-get.

See Solution: Client with the currently selected authenticator does not support any combination of challenges that will satisfy the CA for some alternative workarounds.


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.