Cant renew certificate

Hi, i cant renew the certificate. The certificate is due since 4.4.2019. I dont have experience with certbot. So any recommendations how i can solve the problem?

My domain is:
inkontor.com

I ran this command:
sudo certbot renew --dry-run

It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log


Processing /etc/letsencrypt/renewal/inkontor.com.conf

Cert is due for renewal, auto-renewing…
Plugins selected: Authenticator webroot, Installer None
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for inkontor.com
http-01 challenge for www.inkontor.com
Waiting for verification…
Cleaning up challenges
Attempting to renew cert (inkontor.com) from /etc/letsencrypt/renewal/inkontor.com.conf produced an unexpected error: Failed authorization procedure. www.inkontor.com (http-01): urn:ietf:params:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from https://www.inkontor.com/.well-known/acme-challenge/cPd24ssC5-moyjbAiryxazUk34MWFEa-KkMg1Wjpgk8 [116.203.32.72]: “\n404 Not Found\n

Not Found

\n

The requested URL was”. Skipping.
All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/inkontor.com/fullchain.pem (failure)


** DRY RUN: simulating ‘certbot renew’ close to cert expiry
** (The test certificates below have not been saved.)

All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/inkontor.com/fullchain.pem (failure)
** DRY RUN: simulating ‘certbot renew’ close to cert expiry
** (The test certificates above have not been saved.)

1 renew failure(s), 0 parse failure(s)

IMPORTANT NOTES:

My web server is (include version):
nginx/1.14.0 (Ubuntu)

The operating system my web server runs on is (include version):
Ubuntu 18.04.2 LTS

My hosting provider, if applicable, is:
Hetzner

I can login to a root shell on my machine (yes or no, or I don’t know):
Yes

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):
certbot 0.23.0

Hi @hkiepe

first, your certbot is very old. Perhaps try to update.

Then:

If webroot doesn’t work, you use the wrong webroot. So share

/etc/letsencrypt/renewal/inkontor.com.conf

and the vHost file of your https version. There should be the correct webroot defined.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.