Can't get the script to work - python errors and other problems


#1

I’ve tried setting up LetsEncrypt on several of my VServers, some of which running very old Debian/Ubuntu based systems (which I fully understand may fail for various reasons), but also a rather newly installed system with Ubuntu 15.10.
After initial “git clone” and auto run, it first failed with some obscure non-met requirements of C compiler packages (even though the system has a fully working compiler and tools installed), which I finally seem to have managed to fix. Anyway, now all I get from the letsencrypt-auto script is the following error:

# ./letsencrypt-auto certonly --apache
Updating letsencrypt and virtual environment dependencies......Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-Ss8PsW/cffi

An even newer installed system with Ubuntu 14.04.3 at least ran the script, though that doesn’t help me, as it isn’t my webserver - plus it comes up with this error:

Failed authorization procedure. glendown.de (tls-sni-01): urn:acme:error:connection :: The server could not connect to the client for DV :: Failed to connect to host for DVSNI challenge

IMPORTANT NOTES:
 - The following 'urn:acme:error:connection' errors were reported by
   the server:

   Domains: mydomain.de
   Error: The server could not connect to the client for DV

As the documentation is kept rather simple, and even the “in depth” documentation doesn’t really help me out here, I’m at somewhat of a loss as to how to proceed …


#2

P.S. - managed generating the key manually on the 14.04 server, so at least I can take a look at whether I can get the actual web server to work …