Cannot use https even already finished configure

My domain is: https://www.yan-ziang.com
My web server is (include version): Nginx
The operating system my web server runs on is (include version): Centos 6
My problem is that it also shows the page of Nginx when visit https webpage, and I already check the netcat, 443 port stays on listen state.

I just wanna to know are there some solution to handle the issue.
Thank you.

I already configured the lets encrypt file to Nginx.conf shown in the following sentences.
user www www;
worker_processes auto;
worker_cpu_affinity auto;
error_log /home/wwwlogs/nginx_error.log crit;
pid /usr/local/nginx/logs/nginx.pid;
#Specifies the value for maximum file descriptors that can be opened by this process.
worker_rlimit_nofile 51200;
events
{
use epoll;
worker_connections 51200;
multi_accept off;
accept_mutex off;
}

http
{
include mime.types;
default_type application/octet-stream;
server_names_hash_bucket_size 128;
client_header_buffer_size 32k;
large_client_header_buffers 4 32k;
client_max_body_size 50m;
sendfile on;
sendfile_max_chunk 512k;
tcp_nopush on;
keepalive_timeout 60;
tcp_nodelay on;
fastcgi_connect_timeout 300;
fastcgi_send_timeout 300;
fastcgi_read_timeout 300;
fastcgi_buffer_size 64k;
fastcgi_buffers 4 64k;
fastcgi_busy_buffers_size 128k;
fastcgi_temp_file_write_size 256k;
gzip on;
gzip_min_length 1k;
gzip_buffers 4 16k;
gzip_http_version 1.1;
gzip_comp_level 2;
gzip_types text/plain application/javascript application/x-javascript text/javascript text/css application/xml application/xml+rss;
gzip_vary on;
gzip_proxied expired no-cache no-store private auth;
gzip_disable “MSIE [1-6].”;
#limit_conn_zone $binary_remote_addr zone=perip:10m;
##If enable limit_conn_zone,add “limit_conn perip 10;” to server section.

    server_tokens off;
    access_log off;

server
{
listen 80;
#listen [::]:80 default_server ipv6only=on;

#ssl on;	
# SSL configuration
listen 443 ssl default_server;
ssl_certificate /etc/letsencrypt/live/yan-ziang.com/fullchain.pem;
ssl_certificate_key /etc/letsencrypt/live/yan-ziang.com/privkey.pem;
ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
ssl_prefer_server_ciphers on;
ssl_ciphers 'EECDH+AESGCM:EDH+AESGCM:AES256+EECDH:AES256+EDH';
    server_name _;
    index index.html index.htm index.php;
    root  /home/wwwroot/default;
    #error_page   404   /404.html;
    # Deny access to PHP files in specific directory
    #location ~ /(wp-content|uploads|wp-includes|images)/.*\.php$ { deny all; }
    include enable-php.conf;
    location /nginx_status
    {
        stub_status on;
        access_log   off;
    }

    location ~ .*\.(gif|jpg|jpeg|png|bmp|swf)$
    {
        expires      30d;
    }

    location ~ .*\.(js|css)?$
    {
        expires      12h;
    }

    location ~ /.well-known {
        allow all;
    }

    location ~ /\.
    {
        deny all;
    }

    access_log  /home/wwwlogs/access.log;
}

include vhost/*.conf;
}

Hi @Yanzziang

loading your domain with my FireFox there is no problem visible.

Checked with https://check-your-website.server-daten.de/?q=yan-ziang.com - it’s the same.

There are some “not so good things”, your name servers are terrible, there is no redirect http -> https.

But your non-www and your www-version have the correct certificate, Grade B, that’s ok.

Hi JuergenAuer,

Thank you for your kind advice.
I add a redirect from http to https, and made a new configure on host.conf.
It appears working now.

Thank you !

Yan

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.