Cannot renew SSL certificate after webmin 1.941

OS: CentOS Linux 7.7.1908
Webmin: 1.941

For more than 3 years the Lets Encrypt certificates renewed automatically every 3 months, now I don’t know what happened after last upgrade to Webmin 1.941 or maybe any other updates, but in the Webmin update details that they removed some features about Lets Encrypt which I don’t understand it very well.

I searched the forum before add this topic and I found that is a redirect issue from http to https and some people fixed it successfully but because I’m not so professional I cannot do it. But the question is How you ask me to redirect the https to http while the Lets Encrypt is working for https only?

I’ve removed the option [Apache SSL website enabled?] for that subdomain but the SSL Certificate in the Server Configuration menu disappeared so How do you ask me to redirect https to http.

I think you must fix that issue to be renewed automatically like before.

I need your help with steps as you can because i’m not so professional, Thanks.

The issue details:

Traceback (most recent call last):
  File "/usr/libexec/webmin/webmin/", line 198, in <module>
  File "/usr/libexec/webmin/webmin/", line 194, in main
    signed_crt = get_crt(args.account_key, args.csr, args.acme_dir, log=LOGGER,, disable_check=args.disable_check, directory_url=args.directory_url,
  File "/usr/libexec/webmin/webmin/", line 143, in get_crt
    raise ValueError("Wrote file to {0}, but couldn't download {1}: {2}".format(wellknown_path, wellknown_url, e))
ValueError: Wrote file to /home/DOMAIN/domains/, but couldn't download Error:
Data: None
Response Code: 404
<title>404 Not Found</title>
<h1>Not Found</h1>
<p>The requested URL /.well-known/acme-challenge/thGCxdpRaPdoCXypNexZVzHaj6SDLPvrNMGGLsvOt3o was not found on this server.</p>

1 Like

you are the third person I see with this issue. you should try using certbot as they explain here:'s_Encrypt

1 Like

Yeah, 3rd person indeed. There must be an issue with webmin.

I wouldnt recommend using certbot however, only because, in my experiance, as soon as you manage certs with certbot, outside of virtualmin its very difficult to get virtualmin to manage them for you again. I found the easiest way was to reinstall.

If you can take a look at my thread, and also my post i made in the 2nd person who has had this problem and try those steps to see if the problem is resovled for you that would be helpful. Might be we need to build a picture on this problem and raise a bugfix if it is indeed a webmin specific issue.


Thank you pal, It worked for me.

But it seems it doesn’t work in some systems I don’t know why but I wrote that reply for other people.

In this Webmin Thread it generates an error with some people and the team asked them for the output of the command yum info certbot, So in my case which it worked the output was like in the figure.

Thanks a lot :slight_smile:


Thanks my friend for your help but I think that installing Certbot will be the appropriate solution because the Webmin just removed it from the latest version 1.940 … I know you are a pro and I can’t do what are you done in your threads but I think installing Certbot is correct because in this Webmin Thread they talking about downgrading the webmin version if you don’t want to install the Certbot.

Thanks a lot pal :slight_smile:

1 Like

Hey as long as it works :slightly_smiling_face:

I’ll stop spreading false info about certbot then! I just know i had an issue, but sound like it might have been because i was inbetween webmin versions when had my orignial upset with certbot/webmin.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.