Cannot register account on Staging server


#1

I’m developing a client in Go using lego/acme, I used my own instance of the boulder and everything worked fine.
But I recently switch to the staging server, and I am not able to register an account.

I don’t have any explicit error, just EOF. I don’t really understand because everything worked well with the boulder. I could register an account and get certificate

Is there a way to see what happens on the server side ? It could help me to understand the error.


#2

If you want to use dns-01, use v2:

https://acme-staging-v02.api.letsencrypt.org/

If I know it correct (didn’t used v1), v1 used “register” or something else, but v2 uses new-account.

https://acme-staging-v02.api.letsencrypt.org/acme/new-acct

as endpoint.


#3

Yes sorry I wasn’t clear.
I already use the v2 and I use the newAccount url to register the account.


#4

I solved the problem.
Actually, the CA server responds with 200 and Location header when the account is already registered. That’s why response’s body was empty.
Explanation is here : https://tools.ietf.org/html/draft-ietf-acme-acme-12#section-7.3.1


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.