Cannot obtain SSL certificates for TLD .app domains


#1

Hello everyone,

The TLD .app was released by Google and it’s available since May.
So I tried to generate one single SSL certificate for multiple domains which have the .app extension with the following command:
sudo certbot certonly -d mydomain.app -d www.mydomain.app -d api.mydomain.app -d i.mydomain.app

No matter what authenticator I use, I receive the same error:
An unexpected error occurred:
The request message was malformed :: Error creating new authz :: Name does not end in a public suffix

If I understood correctly it seems that .app extension is not recognized by let’s encrypt as a valid suffix.
There is any workaround I can use to obtain a SSL certificate for my .app domains?

Thank you


#2

You made a typo in your command (the real one anyway). Go back and check it.

Let’s Encrypt does recognize app as a public suffix.


#3

Yes there was a comma instead of a dot.

I need to sleep more.

Thank you!


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.