Can it be that Cerbot removed my HTTP/2 command?


#1

I remeber I added http2 by:

sed -i "s/listen 443 ssl;/listen 443 ssl http2;/" /etc/nginx/sites-available/$domain.conf

I remember I also tested my packets are transferred in http2 here:

https://tools.keycdn.com/http2-test

And I got a positive answer — indeed I use http2.


But today after about a month I checked again and I saw that I don’t have.

Might it be that the weekly-cron certbot renew -q command reverted my Nginx conf file?

If so, how do I make sure it no longer happens?

Thanks !!!


#2

When Certbot adds a new server block, it won’t have the http2 flag.

But it shouldn’t remove it from existing listen directives. :confused:


#3

I’m likely to have a mistake here. Thanks !


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.