Can I tell the http01 challenge to accept 401 status codes?

Error message of cert-manager in Google Kubernetes Engine:
message: "cert-manager/controller/challenges "msg"="propagation check failed" "error"="wrong status code '401', expected '200'" "dnsName"="bm-backend.mycompany.com" "resource_kind"="Challenge" "resource_name"="bm-api-certificate-3892865400-2202752448-1685423685" "resource_namespace"="prod" "type"="http-01" "

This is because we return 401 on purpose when requesting bm-backend.mycompany.com. However we have a 200 status code on bm-backend.mycompany.com/api.

What are ways to get the challenge to succeed? Can I tell “it” somehow to accept a 401 status code as well?

Thanks for any help in advance!

Hi @xetra11

you have to change your configuration, so there is the required answer http status 200.

A protocol isn’t something you can add options “on the fly”.

Ok makes sense!
Thanks for your advice

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.