Can I Change My Domain Name And Request A New SSL Certificate For Webmin?


My questions specifically pertains to changing a domain name and requesting a new SSL certificate for that name just for Webmin login purposes only. So, when I log in Webmin, it will show https. This question has nothing do with typing my WordPress website’s url to see if I connect via https.

Currently, Webmin already includes a Let’s Encrypt tab where you can enter all the requested info. Originally, I accidentally requested an SSL certificate for as opposed to the actual one pointed to my DNS server ( See Pic 1 below:

pic 1

Note, I whited out the website root directory in pic 1 for confidentiality purposes.

Since the certificate was issued successfully under www… and I was able to test it without any issues by logging into Webmin via https, would there be any way in which I can update the certificate to reflect as opposed to

Every time I try changing the domain name and requesting a new certificate for that new name I get the following error message from Webmin:

Requesting a new certificate for, using the website directory /var/…
… request failed : The native Let’s Encrypt client was used previously on this system, and must be used for all future certificate requests

Would it be easier if I can just delete the letsencrypt file directories and start from scratch only this time requesting the certificate for as opposed to the former? If so, which specific files do I remove?

The operating system my web server runs on is (include version) is Ubuntu Linux 16.04.3

My hosting provider is Linode

I can login to a root shell on my machine

I’m using a control panel to manage my site which is Webmin

Any help would be immensely appreciated as I am still a neophyte.

Thank you with generous appreciation!


You can just expand the certificate to include the non-www domain.

Hey Mitchell,

Thank you for responding.

How would I be able to do that?

Also, what would happen if I purposely let my www… certificate expire after 3 months?

1 Like

Not at my desktop right now but there is an expand parameter, I think you just run the same command you used to issue the cert except modifying it to just expand using —expand have a look through for the correct syntax and modify it to just expand the existing cert, don’t forget to add the —dry-run flag to test before you implement

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.