Browsers detects certfiles from certbot as self signed


#1

Hello together,

I have created the cert files using certbot, but when I activate them, then my browser blocks that certificate with the NET::ERR_CERT_AUTHORITY_INVALID error.

My domain is: unifi.foo-bar.rocks
I ran this command: certbot certonly -d unifi.foo-bar.rocks --standalone

It produced this output: congratulations …

My web server is (include version): nginx 1.10.3

The operating system my web server runs on is (include version): ubuntu 16.04

My hosting provider, if applicable, is: strato

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no


#2

If you used certonly, then you need to go and configure nginx to use the certificate you created.

certonly is “don’t install the certificate, I’ll do it myself” option.

If you’ve tried to install it, you’ll need to show us your full nginx configuration.